IS does not start when the BI Process Monitor was installed

When I installed the BI Process Monitor to the Integration server by clicking the file BusinessIntegrator_46_Services_en_US.exe. I chose to install the Process Monitor. Once the installation was complete, the IS does not start.
But when I uninstall the BI Process Monitor or remove the .jar files installed by the BI Process Monitor, the IS can be activated.

Is there any incompatibility issues with the .jar files?or is there any further configuration required?

Have you tried running in debug mode - you may just find what is causing the problem (I had hassles with the classpath becoming too long, with a subsequent failure of IS to start)


I tried to start up the IS using the command line but an error message saying the input line was too long.

I removed some JAR files (mainly the JDBC files and Broker Package files) and it worked!!!

How did you resolve the problem having the classpath too long???

Thanks a lot for the help



As you point out, the problem is that the Windows command-line length limit (256 characters) is being exceeded. This is a general issue that can occur if the root IS install directory path is long and/or you have a lot of jar files in your classpath.

You can resolve this issue moving your jar files into a different directory with a shorter path. You also need to edit the server.bat file. For example, if your new jars directory is ‘c:\webm\jars’, modify the following line:

if exist “%B2B_ROOT%\lib\jars” (
call :appendJarsAndZips “%B2B_ROOT%\lib\jars”

to read:

if exist “c:\webm\jars” (
call :appendJarsAndZips “c:\webm\jars”

Hope this helps.