IS 7.1.2 - Importing SSL certificate fails

Hi everbody,

I am writing this on behalf of a colleague:

We are trying to import a certificate to IS and map the certificate to a specific user.

So first we created a new keypair and a self-signed certificate using java keytool. Then we exported the certificate to a .cer file.

When we try to import the certificate using the admin console we get the following database error:

2010-07-02 17:26:55 MEST java.sql.SQLException: [wm-cjdbc36-0007][Oracle JDBC Driver][Oracle]ORA-01400: cannot insert NULL into (“WMDEV8”.“IS_CERTIFICATE_MAP”.“CERT_SKI”)

We also used a test certificate provided by OpenSSL, which worked and could be imported.

So do we have to convert the certificate in any way before importing it to IS?

Are self-signed certificates supported, anyway?

Thanks in advance,

Case resolved. When using the java keytool to generate a keypair with versions earlier than Java 7 the certificate is lacking the required field.

Solution: Using OpenSSL instead of java.

In case anybody needs this information :slight_smile:


Hi ,

We trying to apply the SSl on the Broker, can you please share across solution which you had applied.

Appriciate your help on this.


Hello Khan,

what exact problem do you need a solution for? :wink:


HI Sascha,

Thanks for the Quick response.

Actually, I have local setp of the wM 7.1.2 environment on the windowsXP platform and tried to apply SSL on the Broker but required KeyStore and TrustStore .

To create the KeyStore and TrustStore, I had used CertificateTool Kit which comes with webMethods Ver 6.5 version ,and then generated the private key(privatekey.der) and CSR Certificate (CSR.pem).

CSR.pem get verified and signed by Verisign test certificate and then tried to generate the keystore and truststore on Unix platform using openssl but this was causing problem and it hampered the complete Broker SSL implementation.

Could you please let me any easy way to achieve this.


Hi Khan,

I am terribly sorry, but I cannot help you with that. We installed an SSL communication for Integration Server not the Broker. I guess that’s a whole different ballgame.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.