Invoking webservice through SOAP_HTTPS

First Query?

I am not able to send the SOAP request to the webmethods IS through XML SPY…
I generated WSDL for the service and i am trying to send to the server for invocation but i am getting error like: Could not post the file soap over rpc (407)…error sending the soap data…

  1. not able to invoke a webservice through HTTPS protocol SOAP-RPC …When i am trying to develop a webservice connector getting below error…

iaik.security.ssl.SSLException: Client certificate rejected by ChainVerifier"

If certificate is expired we will get same error…
We fixed the problem by setting the “watt.security.ssl.client.ignoreEmptyAuthoritiesList=true”
after setting in the server.cnf file, But still i am not able to create a webservice connector getting same previous error…

can u pls suggest me a proper solution for these queries…

Your question is not well organzied, so its a bit tough to understand what you are attempting to do.

First, don’t use soap-rpc. Lots of posts here on why not.

The soap client in XML Spy creates a soap request based on a WSDL file and posts it to the URL found in the WSDL or to an endpoint address that you supply to override what is in the WSDL.

If your WSDL is incorrect either in how it describes the request message for your operation or in the endpoint URL, your request will fail.

Also, during testing, be sure to set the ACL on the Flow service you are attempting to invoke to Anonymous. This should be changed as you promote the code to testing environments.

I have no idea whatsoeer what you are asking in your second question. The Flow generated by the Web Service Connector wizard will successfully invoke a simple soap-rpc or soap document/literal style web service operation if the WSDL (and any imported schemas) are properly formed. However, I do not recommend using the WSC for anything beyond early prototyping. Again, lots of posts here on why not.

Mark

Second question:
“watt.security.ssl.client.ignoreEmptyAuthoritiesList=true” property in server.cnf file in webMethods IS server.

after setting this property in server.cnf file also iam getting following error

certificates rejected by chain verifier…(When i am trying to invoke a flow service through HTTPS protocol)
can u pls suggest me a proper solution i think now u r able to understand…

The watt.security property and the error message you are receiving do not appear to be related.

The certificates rejected by chain verifier can mean 1) the certificate being presented by the client is not trusted by IS 2) the certificate being presented is not properly formed (certificates in chain out of order, one or more expired certs, etc).

Mark

Thnks for u r reply now i able to understood how to invoke the services

You can try setting this property as well.

watt.security.cert.wmChainVerifier.trustByDefault=false

HTH

Krishna

no offense meant…by doing this u r kind of putting ur env at risk. it will accept any certificate…its better to install the certificate on your server and tie that to your partner who is sending the msg. that should more or less solve ur problem. to install a cert and tie it to a partner plz loot a wm administrator guide.