Internal Servlet Error when accessing tamino....

Anybody knows what is the following error mean:

==================================================
Error: 500
Location: /JSP/servlet/Servlets.LoginServlet
Internal Servlet Error:

java.lang.NoClassDefFoundError: com/softwareag/tamino/api/dom/TaminoError
at java.lang.Class.getDeclaredConstructors0(Native Method)
at java.lang.Class.privateGetDeclaredConstructors(Class.java:1576)
at java.lang.Class.getConstructor0(Class.java:1748)
at java.lang.Class.newInstance0(Class.java:266)
at java.lang.Class.newInstance(Class.java:249)
at org.apache.tomcat.facade.ServletHandler.getServlet(Unknown Source)
at org.apache.tomcat.facade.ServletHandler.preInit(Unknown Source)
at org.apache.tomcat.facade.ServletHandler.init(Unknown Source)
at org.apache.tomcat.facade.ServletHandler.service(Unknown Source)
at org.apache.tomcat.core.ContextManager.internalService(Unknown Source)
at org.apache.tomcat.core.ContextManager.service(Unknown Source)
at org.apache.tomcat.modules.server.Ajp13Interceptor.processConnection(Unknown Source)
at org.apache.tomcat.util.net.TcpWorkerThread.runIt(Unknown Source)
at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(Unknown Source)
at java.lang.Thread.run(Thread.java:536)

==================================================

This error occurred when I try to retrieve values from tamino to validate with the user’s input. I am developing with JSP and servlets and this happens when running the servlets. I tried the normal way of servlet which uses normal database like Microsoft Access and it works. Only when trying to get values from Tamino, this error occurred. Can anybody help me how to solve this error?? Is it due to the setting of the classpaths?? But the examples such as DemoQuery.java and DemoInsert.java works perfectly fine… i have set the classpaths as specified in the Tamino documentation for Java API. PLease help… :frowning:

Hi,

1) What version of Tamino are you using?
2) Did you know that there is a newer version of the Tamino Java API (that supports other object models like SAX, JDOM and raw streams, in addition to DOM)?
3) Have you tried adding taminoclient.jar; xp.jar; xt.jar; w3cdom.jar into the WEB-INF/lib directory of your web application (assuming you’re using Tomcat 3.x and above) and restarting Tomcat?

Cheers,
Puny Sen

Thanks for the help. I tried to put all the jar files needed into the WEB-INF/lib directory of my application and everything works fine!

Thanks once again.

Regards. :slight_smile: