Installation Grief WM601 No Server Visible

Hi,

I have just downloaded an evaluation copy from WebMethods for 6.0.1 and created an installation image. This file is 338MB which I presume is correct (even though the installer said it was dowloading 600+MB). I used this image to install all WM components, including the integration server as an W2K Service.

Once it had installed, I checked the services screen and noticed that althougth the Broker and Broker monitor were started, the IS was not started. I tried to start this and an error message was put into the system log with an error code of 2147500037 & -2147467259 appeared in a messagebox.

I carried on anyway and it seemed that the IS Administrator was running as I was able to access it through the localhost:5555.
I carried out all required installation steps and then installed the MQSeries adapter, which seems to have completely crashed everything. I can no longer stop, start or access the IS Server.

I have uninstalled and re-installed the evaluation copy, but things seem to be different, namely that the installation no longer installs a log directory and all the *.cnf files in the config directory. I donlt know if anything else is missing, but I would assume so.

Sorry for the long message, but I am completely at a loss as to what to do next. Can anyone please help me to get this installed?

Thanks

Tim

Hi Tim,
Lets start with please don’t post in multiple forums. It’s an honest mistake.
I can’t say I know why the download image did what it did. We’ve had lots of problems trying to get IS to start in a windows serice. We gave up until it becomes a requirement.

However, once an IS crashes, look under the Integration Server directory. IS creates a file called “LOCKFILE”. This stop IS from attempting to start if the file exists.

Now that you know that trick, a fresh installation of IS does not include the server.cnf file or any log files until the server is started for the first time.

Let us know how you progress.

HTH,
Jim Palmer

Jim,
Thanks for the reply. We have re-installed all the webmethods 6.0.1 components, this time as a windows application. As you say the Server.cnf file is missing, as is the log directory. We have clicked on the WebMethods Integration Server icon is the WebMethods6>Servers menu in the start bar, but still nothing is happening. The lockfile is there in the main IS folder, and does not disappear. Does this mean are IS is crashing everytime? According to the Administraot rguide, if I delete this file I should be able to restart. (P.S. - We still cannot access the Administrator from the front end on port 5555).
Any further ideas would be much appreciated as to how to get this running?
Thanks
Tim

Tim,
I was experiencing problems similar to those you mention in your post. In particular, when I would start the wM6 service I would get a message box indicating the same error code (2147500037) you were getting. I happened to look in the application event log and found that there was a message there also that indicated that the service was unable to start the jvm because the classpath was empty. I found the service definition in the system registry and sure enough the classpath string (and some other strings) were not defined. This seemed like a smoking gun so…

I know that the service executable ISNTSvc.exe invokes <is>\bin\server.bat as follows:
server.bat -service wmIS
when the service attempts to start wM.
So i tried opening a command prompt and invoked server.bat with that same syntax. When I looked at the service registry entry again I saw several new entries, including classpath. Then I tried to start the wM service again and it worked!!!

I have no idea why running server.bat manually caused the service registry entries to be properly updated, but it is clear to me that this was the problem.

Perhaps it was because I did not reboot the OS after installing IS and attempting to start the service the first time(s). Another posibility is that I have an older version (wm4.6) also installed on this box. Maybe there is some conflict.

I have reported this sequence to wM support, but have not yet received a response.

Please note that I do not advocate editing the registry with regedit. It is simply too easy to mess things up.