Install failed to install ActiveWorks Adapters 4.0 Service

Install failed to install ActiveWorks Adapters 4.0 Service, can’t configure adapter.

I may have a problem related to another in the Troubleshooting forum, I have two CPUs and the
JDK that comes with weebm 4.1 doesn’t support multiple CPUs. I installed Java SDK 1.4.0 and now most apps seem to run (some Java AWT exceptions) but, how do I retroactively install this missing

The explicit statement from several webMethods consultants ist that for Enterprise Server v4 you must by no means use a JVM other than v1.2 (at least on UNIX). With 1.3 you cannot e.g. start adapters in debug mode and may probably encounter all sorts of other errors. The same probably applies to v1.4.

Did you just install JVM 1.4 on your machine in the normal way or did you replace the one that comes wihtin the Enterprise Server directory?

Ok, I can take out 1.4.0 and install any VM (assuming multiple CPU compatable) on NT 4.0.

Now, how do I install this missing service?

Thanks in advance,
Brian Downing

Have you tried re-installing one of the adapters? That should install the service.

I uninstalled, and reinstalled
to no avail, still no service.

Brian Downing

We had a similar issue with the installation itself failing (on NT box). We had to remove the references to earlier (1.1, 1.2) versions of the JRE environments in the following hive (we had 1.3.0 JRE installed) :

HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment

You should export the full key in its original form before you make any changes to it in case you need to restore (as long as you have 1.3 installed, you’ll be okay). Then run the installer for the adapters, it will complete.