INOXQE6301 Runtime type exception

Hello,
I am trying to run this query from Interactive Interface and get this exception :

My database is version 4.1.1 and I have data in the schema

declare namespace
ft="http://www.w3.org/2002/04/xquery-operators-text"
for $x in input()/Patient[ft:text-contains(Case/Exam/Story,“kirik*”)]
return $x

This is the exception :
<ino:message ino:returnvalue=“6301”>
<ino:messagetext ino:code=“INOXQE6301”>Runtime type exception</ino:messagetext>

Hello there.

I tried a very similar query with Tamino 4.1.1.9 and the “patient” schema, which worked.

Here it is, just for those interested:

   declare namespace ft="http://www.w3.org/2002/04/xquery-operators-text"
   for $x in input()/patient[ft:text-contains(name/surname,"At*")]
   return $x


Could you please tell us the type of the Story element in your schema?

Thanks,
Trevor.

Story is an Element Simple
variety : type / restriction
type : xs:string
Collation : no
index : text
dereference : no

I installed Tamino Update Kit 4.1.1.9 and still get the same exception

thanks Server

[This message was edited by MehmetServer on 02 Apr 2003 at 10:06.]

Hello Server,

I’m sorry - I still can’t reproduce the error.

I also have 4.1.1.9, but even after I created a text index the query still works on the “patient” schema shipped with Tamino.

Could you please post your Patient schema?

Thanks,
Trevor.

Hello,
I have tried same query when there are about 100 documents in the database and it worked didnt cause any exception.
I have more than 90000 documents in my application probably this might cause the exception.
Or do you think it might be because of any specific data in this node?
I can mail you the schema if you want but it seems as if the problem is not with the schema but the data :frowning:
Can you help me Trevor?
Thanks Server

Hi Server,

yes, I will certainly try to help you!

If you could e-mail the schema and a few example documents to me (my e-mail address is in my profile) I will investigate the problem.

In the interests of being completely honest I should point something out though: if you have a support contract, you will get an official solution faster if contact your local Software AG Customer Support Center.

Greetings,
Trevor.

Hello ! :slight_smile:

I’me having the same exception when i do something like this:

declare namespace ft="http://www.w3.org/2002/04/xquery-operators-text"
for $a in input()/doc[ft:text-contains(@*,‘1’)]
return
$a

I’m i doing something wrong?
It should be possible to query all the attributes of the element this way, am i right? :confused:

Thanks in advance …

Rui Leal

Hello Rui Leal,

In your case the runtime exception is caused by the first parameter to the text-contains function. It must be a node and you are specifying a nodeset.

Hope this helps.

Stuart Fyffe-Collins
Software AG (UK) Ltd.

Oops! :slight_smile:

Thanks … of course that was the problem!

I’ve been coding a lot of XSLT and was thinking about the function “contains” which can take a node-set as a parameter !

But …

Is there any way to know what throwed (?) the exception? Some log for example?

Rui Leal

Generally the xquery processor will provide enough information if the query is wrong and will give a line/column number. However I think when things get down to the functions and there is a parameter error for example then all you get (currently) is 6301 Runtime error. Maybe this will change in the future. Generally I think you can look to the functions for the cause of such errors.

Hope this helps.

Stuart Fyffe-Collins
Software AG (UK) Ltd.

hello,

I am geting the same error while running the following Xquery only when a document has
a dateOfService equal to the one I am querying for (otherwise it works fine):

for $a in input()/doc:revisionDoc
where (($a/doc:header/pat:patientRecord/pat:dateOfService >= xs:date(“2003-04-25”)))
and $a/@clientId = 1
return

{ $a/@id }{ $a/@clientId }{ $a/@documentId }{ $a/@revisionNumber }

sort by (@documentId, @revisionNumber)

Any Suggestion? Thank you for your help.

Eric