Initialization of numeric arrays


does anybody know about changes in numeric array initializations from Nat3.1.x to Nat4.1.4. I have got the following problem:

1 #ARR (N2/1:10) CONST    
  (*)  <-1>                
  (01) <01>                
  (02) <02>                
  (03) <00>                
  (06) <00>                
  (07) <00>                
  (08) <08>                
1 #I (I4)                  
FOR #I = 1 TO 10          

The occurences 3, 6, 7 are not initialized with zero, but stay to contain -1 (the first step init value).

I think, SAG has “optimized” the init/const statement to avoid initializations with zero values for numeric arrays. Unless you don’t initialize an occurence twice, this seems to be ok. But in my case, it is not!

Is there a ZAP or so available to avoid this problem? Does this problem exist with Open Systems, too?

On Windows it works OK and sets occurs 3,6, & 7 to 0.
Mainframe NATv4.1.3 it gives the same results you see both with and without NOC.
Have you opened a support request?

This looks like a bug.
I have tried it with NAT 4.2. and it is still the same. :cry:
I would recommend you to open a support request.

It is working fine for me in NAT 3.1.06