improving adapter performance

I have an oracle adapter which is taking about 2 minutes to bring the data from the database. If I do same query in the database directly, it is coming back in 30 seconds. What should I do to improve the adapter performance?


Hi Ramesh,

I am facing the same problem with the db Adapter.Can you please share the solution with me.



I develop the java component (using the webMethods API) that does the same thing as of my adapter. The performance difference is 10 seconds (for java) versus 2 minutes (for adapter).

Really really need some guru out there to enlighten us on performance tuning for adapter.


What version of webMethods are you using? What version of the adapters? Where is your adapter configured (on the same machine as the webMethods server, on the same machine as the Oracle server, somewhere else)? Are you using an Oracle adapter or is it JDBC connecting to Oracle? If JDBC, what version of the Oracle JDBC driver? If not, what version of Oracle tools? For that Java service you wrote, how is the connection being made - is it JDBC?

This is just some of the information that you need to provide if you want a useful answer to your question. Please be much more detailed in the future if you’d like help.


Thanks for the tip, Skip,

I’m using…
webMethods Enterprise 5 (Win2K machine),
JDBC adpater 4.6 (installed on another Win2K machine) connecting to Oracle 8i database (solaris machine) using JDBC Type 4 driver.

The java app i wrote runs on the same machine as the adapter and connects to the same broker and same database using the same driver.

Both reads data (for notification) from a buffer table that has only one string field. The test I did are for publishing 1000 records.


Have you tried running the adapter in debug mode? That will let you see the actual SQL being run, and you might see some other interesting debug messages.

Other than that, the only suggestion I have is to check your network architecture. Your Java app is going from the adapter box to the Oracle machine, while the adapter is going from the adapter box to the Oracle machine and then to the Broker, and that happens for every notification. If there’s a poor network connection from the Broker to the adapter it will cause slowness.

Have checked the network and database. Both’s fine.

One thing though, if either the network or database had been the problem, both the adapter and java app would have been affected. So why the big difference in performance between the two?

Did you read my previous response? As I said, there is an extra network step from the adapter to the Broker with webMethods, while that step does not exist for your Java application. That was why I suggested that the network connection could be the issue. Also I suggested running in debug mode and I don’t see any mention of the results of that.

You need to take this up with webMethods support, professional services, or a business partner that can talk to you directly, possibly even come on-site and have a look at your setup. It’s difficult to do any kind of useful troubleshooting through a forum like this, and performance problems are the worst kind of issues to resolve.

I don’t understand why there isn’t such a step with my java app. Both needs to connect to the broker in order to publish events right?

Actually, the reason for posting to this forum is not so much as to solve the performance probelm but to check with all the experienced ppl out there whether any of you have this type of performance issue.

Thanks for your help.

My apologies, I thought your Java app was directly querying the database. I didn’t see that you used the webMethods API. In that case, you are correct, the network should not be an issue.

I again suggest that you run the adapter in debug mode. This output should give you an idea of how long the actual database query is taking vs. anything else that is happening in the adapter.

the debug screen is moving too fast and the export is capturing too little information.

is there anyway to pipe the debug info into a file?

Have you solved this issue ? I started faced the same problem in WM6.