Importing 6.1 Models into 7.0

Hey Gang,

I have been trying to import a process model from a 6.1 instance into my new 7.0 installation. I have been trying to use the Import Wizard in the Designer tool whereby it asks me the 6.X design server to connect to and take out the model from.

Whenever I use the location of a 6.1 Design Server it doesnt like it and says it cant find the design server, but if I point it to a 6.5 Design Server then it imports the model great.

If you try the offline mode of import it asks for the 6.5.X installation directory of modeller on your filesystem, im not sure how that is supposed to get you the models.

I was hoping the import wizard would just want to be pointed at my .model file i exported from 6.1 modeller.

Has anyone tried to import a model from 6.1 into 7.0?



Hi Louis,

I guess importing process models in designer is only supported for 6.5 models.

Migration of data of 6.1 is not supported in 7.0, I guess it will be supported in 7.1 release.


Hi Mate,

you say that you “guess” a few times, does that mean you know for sure migrating 6.1 models isnt supported in 7.0 and its not just a bug or something else?

The import wizard says “Import 6.x Models”, I would have hoped if they really only meant 6.5 they would have said that.



I found out from WM support that importing models from a 6.1 design server is indeed broken in this version.

You have to import in “offline” mode and the directory isnt the modeller directory but the Servers/Repo directory of the IS server. This also only works if the models are stored in the repo as “flat file”. If they are in the DB, export the models, change to flat file and then reimport.

Once you import check any complex joins as the import breaks them


I know this is an old post but I am curious if any solution has been found to import problems of 6.1 to 7.0 or 7.1 Designer? You mentioned TS confirmation of broken process/feature is that supposed to be fixed in some SP or 7.1.1 versions? I have made several attempts to import 6.1 into 7.1 and they still do not work with all latest fixes to Designer.

You also mentioned broker Joins this is of special interest to me because 6.1 suport for XPATH and global data now deprecated in 7.1 and I do not see a way to use parameter values as timeout inside models. It seem that 7.1 Designer support 3 types of timeouts: static value, Business calendar and Field value. The static value and Business calendar is basically hardcoded values that work only in special cases. AN d field value is supposed to be some pipeline or document var but I never able to set this field value so it can be used as timeout. The b ig question is how to use parameter variable as timeout?

Hi i’m trying to import Models from 6.1 Modeler into Designer 7.1.2. I tried the option of Import and given the design server parameters(wM 6.1 design server i.e. where the 6.1 models sits) to connect to Design server. But, its throwing me the error like,
“Unable to Connect to Design server. Please check your connection parameters”.

Please let me know if some one tried the same & got any solution to resolve this problem. I heard that adding a parameter ‘-DnoCheckMDP=true’ in eclipse.ini file in eclipse folder of wM71 installed directory can solve this. Even this doesn’t helped me out. Please get me if some other fix is there to solve this problem.



Design server is the IS 6.5, so you have to start 2 IS in order to import models from 6.1 to 7.1.2, the design will be like chaos, you should put them back in order like in the modeler.


Thanx for ur reply. Here, the design server was 6.1 in our case and was running. Also the 7.1.2 runnig. But, still facing the same problem while trying to connect to design server using the credenitals of wM6.1 IS during import.