I am unable to launch the TN Console

I can’t launch TN Console or Developer. When I lanuch then from console
or command prompt then I would get to the initial logo screen and there
after would get stuck.

Based on the suggestion these are the changes I have done to my system.

1)Initially JVM was installed on my system
2)Then I have installed jdk 1.3.1_09
3)After this I have modified the TNConsole\bin\console.bat

'Commented the below change
rem SET JAVA_ROOT=D:\Program Files\webMethods6\jvm\win142
'Added the following line
SET JAVA_ROOT=C:\jdk1.3.1_09

After this change when I launch the TN Console from the console or from the command prompt then it would display the TNCONSOLE initial log screen alone and remain stuck,
I mean it just show the logo screen and would not go the TN Console at all. The same thing also happens for the developer.

My colleague told me it could be b’cos I have installed the web methods under d:\proram files and not on the root directory.

Please also note that the following error message written when I attempted to launch the TN CONSOLE from the command prompt.

Please advise.

com.wm.proxy.ProxyException: failed to invoke proxy method
null

    at com.wm.proxy.Proxy.invokeStaticMethod(Proxy.java:168) 
    at com.wm.app.tn.ui.proxy.TNLauncher.start(TNLauncher.java:39) 
    at com.wm.app.Application.start(Application.java:354) 
    at com.wm.app.Application.launch(Application.java:468) 
    at com.wm.app.tn.ui.Main.main(Main.java:26) 

Proxy invocation target stack trace:
java.lang.NoSuchFieldError: GRAY
at com.webmethods.caffeine.plaf.Colors.<clinit>(Colors.java:20)
at com.webmethods.caffeine.plaf.CaffeineTheme.initializeColors(CaffeineT
heme.java:156)
at com.webmethods.caffeine.plaf.CaffeineTheme.initialize(CaffeineTheme.j
ava:73)
at com.webmethods.caffeine.plaf.CaffeineLookAndFeelII.initComponentDefau
lts(CaffeineLookAndFeelII.java:141)
at javax.swing.plaf.basic.BasicLookAndFeel.getDefaults(BasicLookAndFeel.
java:57)
at javax.swing.plaf.metal.MetalLookAndFeel.getDefaults(MetalLookAndFeel.
java:1032)
at com.webmethods.caffeine.plaf.CaffeineLookAndFeelII.getDefaults(Caffei
neLookAndFeelII.java:407)
at javax.swing.UIManager.setLookAndFeel(UIManager.java:356)
at com.wm.ui2.UiApplication.init(UiApplication.java:121)
at com.wm.ui2.UiApplication.<init>(UiApplication.java:95)
at com.wm.app.tn.ui.TradingNetworks.<init>(TradingNetworks.java:58)
at com.wm.app.tn.ui.TradingNetworks.create(TradingNetworks.java:46)
at com.wm.app.tn.ui.TradingNetworks.main(TradingNetworks.java:214)
at java.lang.reflect.Method.invoke(Native Method)
at com.wm.proxy.Proxy.invokeStaticMethod(Proxy.java:166)
at com.wm.app.tn.ui.proxy.TNLauncher.start(TNLauncher.java:39)
at com.wm.app.Application.start(Application.java:354)
at com.wm.app.Application.launch(Application.java:468)
at com.wm.app.tn.ui.Main.main(Main.java:26)

Christopher,

Did you ever solve this problem?

I have just started to get it when trying to start up webMethods Integration Server and cannot work out what has changed on my system to cause this to happen. Even reinstalling didn’t solve the problem.
Here is my stack trace:

C:\>com.wm.proxy.ProxyException: failed to invoke proxy method
null

    at com.wm.proxy.Proxy.invokeStaticMethod(Proxy.java:168) 
    at com.wm.app.server.ServerProxy.ServerMain_main(ServerProxy.java:77) 
    at com.wm.app.server.ServerApp.start(ServerApp.java:105) 
    at com.wm.app.Application.launch(Application.java:468) 
    at com.wm.app.server.Main.main(Main.java:50) 

Proxy invocation target stack trace:
java.lang.ExceptionInInitializerError: java.lang.IllegalArgumentException
at sun.net.www.ParseUtil.decode(ParseUtil.java(Compiled Code))
at sun.misc.URLClassPath$JarLoader.getJarFile(URLClassPath.java:531)
at sun.misc.URLClassPath$JarLoader.<init>(URLClassPath.java:501)
at sun.misc.URLClassPath$2.run(URLClassPath.java:297)
at java.security.AccessController.doPrivileged(Native Method)
at sun.misc.URLClassPath.getLoader(URLClassPath.java:286)
at sun.misc.URLClassPath.getLoader(URLClassPath.java:250)
at sun.misc.URLClassPath.getResource(URLClassPath.java:163)
at java.net.URLClassLoader$2.run(URLClassLoader.java:486)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findResource(URLClassLoader.java:483)
at java.lang.ClassLoader.getResource(ClassLoader.java:1029)
at java.lang.ClassLoader.getResourceAsStream(ClassLoader.java:1190)
at java.lang.Class.getResourceAsStream(Class.java:1260)
at javax.activation.MailcapCommandMap.loadResource(MailcapCommandMap.java:173)
at javax.activation.MailcapCommandMap.<init>(MailcapCommandMap.java:162)
at javax.activation.CommandMap.getDefaultCommandMap(CommandMap.java:55)
at com.wm.net.mime.DataContentHandlerFactory_WM.init(DataContentHandlerFactory_WM.java:27)
at com.wm.app.b2b.server.Server.<clinit>(Server.java:112)
at com.wm.app.b2b.server.Main.main(Main.java:40)
at java.lang.reflect.Method.invoke(Native Method)
at com.wm.proxy.Proxy.invokeStaticMethod(Proxy.java:166)
at com.wm.app.server.ServerProxy.ServerMain_main(ServerProxy.java:77)
at com.wm.app.server.ServerApp.start(ServerApp.java:105)
at com.wm.app.Application.launch(Application.java:468)
at com.wm.app.server.Main.main(Main.java:50)

Thanks,

Anthony

He Anthony? Hows life?

Have you guys tried running the Console with -debug option?

c:\console>console.bat -debug 9 -log -

Also I would not recommend JVM 1.3.1_09 as it has some weirdness in it as seen within scheduler of IS.

Furthermore what version are we talking about? 6.0.1? and what fixes/SP’s? Console 6.0.1 with IS 6.0.1? Are you able to connect to IS using Developer? Have you tried reloading the WmTN package.

-Jordy

Hi Jordy,

I made the cardinal sin of posting to a thread that has a different problem to mine (slightly).

MY problem is that I cannot start IS 6.1 (and get the above stack trace when I try). Previous to the last week or so, it has been running happily on my laptop (XP, 1.8GHz, 1GB Ram) including when working at home and connecting to my company network over VPN using a cable modem. I have recently changed two things on my laptop:

  1. Installed a router to split my broadband connection. This means that I now connect using an RJ45 cable instead of USB.
  2. Installed a product called Contivo (a design time tool designed to work with webMethods).

I have been speaking with Contivo support and we spent a couple of hours on Tuesday trying to solve the problem but to no avail. I have also tried disconnecting from the router and releasing the ip address but that doesn’t seem to help either.

Finally, I gave up and uninstalled, rebooted, and then reinstalled but I still get the same problem.

I have not tried to add any patches or service packs because it has always worked fine before. The only thing that is changed from the standard install is that I use the Java 1.4.2 from %WM_HOME%\jvm\win142 as the %JAVA_DIR% on the recommendation of a PS guy (although I have since tried using the stanard version too).

Any further thoughts much appreciated.

Regards,

Anthony

P.S. A belated Happy Queens Day!

I’m also getting the same problem while starting IS 6.1 on my m/c. The exception and stack trace is same as mentioned above. Can anyone suggest any solution for this. I have tried re-intalling complete webMethods suit on my m/c but it didn’t work !! It was working fine earlier. I have recently installed Oracle client and Toad on my m/c. Can it change something to result this problem ?

Were you guys able to solve this issue? I am getting the same error when I am trying to lauch developer from TN (While choosing a service for processing rule).
This used to work fine for me and started giving problem since I have installed Oracle 8.1.6. I have tried uninstalling and installing the TN but in vain.

Please let me know if you have found the solution.
Thanks,
Pankaj

Has anyone had resolution to this type of problem? I am encountering the same type of error and haven’t seen any posted resolutions.
Below is the log display from developer.bat, at which point the process “hangs”. Any input would be greatly appreciated.
Developer 6.0.1 Build 425
com.wm.proxy.ProxyException: failed to invoke proxy method
java.lang.reflect.InvocationTargetException:
null
at com.wm.proxy.Proxy.invokeStaticMethod(Proxy.java:168)
at com.wm.app.dev.DevMainProxy.main(DevMainProxy.java:78)
at com.wm.app.dev.DevMainProxy.start(DevMainProxy.java:156)
at com.wm.app.Application.start(Application.java:372)
at com.wm.app.Application.launch(Application.java:490)
at com.wm.app.dev.Main.main(Main.java:43)

The invocation target’s underlying exception was the following:
java.lang.NoClassDefFoundError: com/webmethods/caffeine/api/extension/AbstractEx
tension
at java.lang.ClassLoader.defineClass0(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:486)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:11
1)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:248)
at java.net.URLClassLoader.access$100(URLClassLoader.java:56)
at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
at com.wm.util.classloader.AdvisoryClassLoader.findClass(AdvisoryClassLo
ader.java:147)
at java.lang.ClassLoader.loadClass(ClassLoader.java:297)
at java.lang.ClassLoader.loadClass(ClassLoader.java:253)
at com.wm.ui.pluggable.ApplicationPlugInLoader.createNewPlugIn(Applicati
onPlugInLoader.java:174)
at com.wm.ui.pluggable.ApplicationPlugInLoader.registerStartupPlugIns(Ap
plicationPlugInLoader.java:881)
at com.wm.ui.pluggable.ApplicationPlugInLoader.initialize(ApplicationPlu
gInLoader.java:519)
at com.wm.ui.pluggable.ApplicationPlugInLoader.startPDVLoading(Applicati
onPlugInLoader.java:218)
at com.wm.ui.UiApplication.loadPlugins(UiApplication.java:229)
at com.wm.app.b2b.dev.DevMain.run(DevMain.java:230)
at com.wm.app.b2b.dev.DevMain.main(DevMain.java:809)
at java.lang.reflect.Method.invoke(Native Method)
at com.wm.proxy.Proxy.invokeStaticMethod(Proxy.java:166)
at com.wm.app.dev.DevMainProxy.main(DevMainProxy.java:78)
at com.wm.app.dev.DevMainProxy.start(DevMainProxy.java:156)
at com.wm.app.Application.start(Application.java:372)
at com.wm.app.Application.launch(Application.java:490)
at com.wm.app.dev.Main.main(Main.java:43)

I found the below info in one of the readme files for Developer.
Try it… it worked for me.

To launch webMethods Developer 6.1 Feature Pack 1 from webMethods Trading Networks, you need to modify the console.bat file (Windows environment) or the console.sh file (UNIX environment).

If you are running Windows:

1 Navigate to the <tnconsole_directory>\bin directory and open the console.bat file.

2 Scroll down to approximately line 16, where you find the “SET CLASSPATH=…” line. At this line, add the following after %SSL_PATH%:

;%B2BDEVDIR%…\common\lib\fabricClient.jar

3 Save console.bat.

If you are running UNIX:

1 Navigate to the <tnconsole_directory>/bin directory and open the console.sh file.

2 Scroll down to approximately line 87, where you find the “CLASSPATH={CLASSPATH}:{DEV_JAR}” line. Insert the following line above that line:

CLASSPATH={CLASSPATH}:{B2BDEVDIR}/…/common/lib/fabricClient.jar

3 Save console.sh.