HTTP with post Method

I am trying to create a poc where I execute a REST webservice on another internal server from within webMethods IS. The REST service instructs me to use the POST method. It also instructs me to
“Body of the POST request should contain XML representation of the search parameters as in the following example:”

… Other settings and parameters

I can build the xml string that contains these parmaters without issue, but what I cannot get to work is the actual service. I have tried mapping this XML to data/string, data/bytes (after converting to byte array), and data/stream. Nothing seems to send the xml to the service. I do not believe it is the XML string that I have built because I can cut and paste the string value (from IDE when tracing flow service) into soapUI where I am running and testing the same REST service and SoapUI works properly. Why do I not get same results in IS? Is “body of the POST” data or headers?

When posting the XML are you setting the content type “text/xml” to the IS service?


Thanks, once I set the content_type to text/xml, it worked as expected.

Glad to hear back issue resolved: