HTTP maxKeepAliveConnections and keepAliveTimeout


I’m using wmPublic service pub.client:http to make high volume HTTPS requests to a webService over the Internet and I’ve confiured the “timeout” key on the HTTP request. Occasionally I’m experiencing a “timeout” issue and it appears to be related to our proxy server rather than the webService I’m calling. Not sure what the reason is for the intermittent timeout issue although I will be investigating further

I’ve carried out a load test and I can see that our Integration Server establishes connections to the proxy server and I can see that after a short period of time, the connection is closed.

I’ve read the manual regarding the keepAliveTimeout and maxKeepAlive Connections and I can see the benefit in configuring these values.

Our is set to the default value - 300 seconds and our keep alive time on our linux server is 7200 seconds.

Before I configure these values, does anyone have any recommended settings for these or is there anything that I need to be aware of?

I’ve found a previous comment suggesting to set watt.server.keepAliveTimeout=300000 however there’s no follow up comment to say whether it resolved the issue.

Any comments or thoughts are greatly received :smiley: