How to start up the workflow server

Please browse:
http://www.wmusers.com/wmusers/messages/1829/15292.shtml

And also there are many threads posted under the (
wMUsers Discussion Forums » webMethods Business Analytics » webMethods Workflow ») facing the same startup problems.

HTH.

I do it follow the solutions from http://www.wmusers.com/wmusers/messages/1829/15292.shtml ,but the problem still exist.

I think that the server class maybe not find the classpath for the PDClassServerImpl_Stub,I want to know where and how I can set the classpath?

Thanks.

Zhang,

Kindly check this posting also,some useful suggestion posted by Ray Moser:
http://www.wmusers.com/wmusers/messages/1829/15292.shtml?1069099684

And seems you are also using port 5000,there are some thoughts he pointed on using ports for winXP client.

HTH.

HTH,

thank you for your kind help , but the problem still not be solved ,I have tried to change the port by the config tools ,change client corresponding,but it still tell me that the server is not active.

Thanks.
Xisheng.

experts,

Could you tell me how to set the classpath for WM workflow server?

Thanks.

Experts,

I have many times to add ,change the classpath in the srvmgr.bat file and classrv.properties file . but the workflow server still don’t find the class . I attach My several file relative to the workflow server,could you help me to find what I have missed.

Thanks you very much.

Xisheng.

classrv.properties
classrv.properties (13.8 k)

srvmgr.bat
srvmgr.bat (4.8 k)

this the server log for your information.

log
servermgrlog0.txt.bak (9.8 k)

Experts,

sorry ,for my disturb, but I am urgent to get the solution on the upper.

Could you help me on this .

Thank you very much.

Xisheng.

Experts,

when I´m trying to start the Workflow Server I got follow error:

3/5/04 [05:17:37.962 PM] [WKS.000.0017] Creating new registry for 6,501.
java.rmi.ConnectIOException: error during JRMP connection establishment; nested exception is:
java.net.SocketException: Connection reset
at sun.rmi.transport.tcp.TCPChannel.createConnection(TCPChannel.java:274)
at sun.rmi.transport.tcp.TCPChannel.newConnection(TCPChannel.java:171)
at sun.rmi.server.UnicastRef.newCall(UnicastRef.java:313)
at sun.rmi.registry.RegistryImpl_Stub.list(Unknown Source)
at com.wm.zeus.pd.servermgr.server.LocalRegistry.<init>(LocalRegistry.java:72)
at com.wm.zeus.pd.servermgr.server.LocalRegistry.getInstance(LocalRegistry.java:56)
at com.wm.zeus.pd.servermgr.server.ServerManagerImpl.<init>(ServerManagerImpl.java:378)
at com.wm.zeus.pd.servermgr.server.ServerManagerImpl.main(ServerManagerImpl.java:1557)
Caused by: java.net.SocketException: Connection reset
at java.net.SocketInputStream.read(SocketInputStream.java:168)
at java.io.BufferedInputStream.fill(BufferedInputStream.java:183)
at java.io.BufferedInputStream.read(BufferedInputStream.java:201)
at java.io.DataInputStream.readByte(DataInputStream.java:331)
at sun.rmi.transport.tcp.TCPChannel.createConnection(TCPChannel.java:215)
… 7 more

Could you tell me how to solve the problem ?

Thanks !

Here is what I found out on the webMethods Advantage site.

Assuming you have correctly isntalled and configured the workflow server. You will get the above error if you use “localhost” for the workflow server name. It seems that java RMI does not work well with a “localhost” name. All I had to do is use the workflow configurator and enter my server name instead.

Also make sure the port you are using for the workflow server is not already being used by something else! See netstat -a

Hi All,

I am Working with IS6.0.1SP2 and DeveloperSP1,i configured workflow server and client , both are running fine, when i configure Physical Server(IS) in WmAdmin window,it is configured without error, but when i configure Physical Server(Workflow) giving RMI(5001) and central host ports(5000)

Error thrown::
Failed to retrieve resource information from the server<servername>
Error:
com.wm.app.b2b.client.ServiceException:[ISC.0064.9324]Server Error:Not Implemented

Even changing ports to 6000 and 6001 respectively does not works.

Can Anybody help??

Regards,
Puneet Saxena

Try Changing the ports with 9000 and 9001 respectively and give it a shot.

HTH,

Hi RMG,
Thanks for contibuting …but it’s not going either with said solution.

Regards,
Puneet

HI Puneet

Have you fixed your problem yet? Are you seeing this error from your workflow configurator or the wmAdmin when setting up your servlet?