How to kill a wait


Does anybody knows how to kill a wait that has no time parameter ? i’ve got 8 of them running as shown in service usage :
pub.sync:wait (8)
they’re waiting for documents that will never come

first thing we could do is create ‘manually’ those documents
but if there was much more services it would be tedious

would it be possible to kill them ?

thanks for your help,

let’s precise things :

  • i was able to stop the wait by running some notify with the good keys (fortunately i knew their values)
  • but it still have some publishandwait waiting and i haven’t got the values of the _env/pubId to generate a deliver

how can i kill those
pub.publish:publishAndWait (7)

(restarting the IS is not enough)

What do you have your wait timeout set for on your publishandwait service? If you don’t have a value there it will wait indefinitely.


You can also reload the package - either your package or wmPublic from the Administrator screen under package/management.

thanks to you both for your answers
Mark, the value on publishAndWait is now set to 4 hours
still it is a lot to wait when we’re testing

Jon, reloading the packages seems to reset the triggers (if they were filled up they are free again) but does not seem to kill the publishAndWait at all

restart of the IS seems to help : it reduced the amount of publishandWait running to 11

still 11 is too much : it is jamming my next requests

so if i can’t kill the publishAndWait, another way to sort out this problem would be to raise the number of possible publishAndWait ; the thing is i don’t now which setting is concerned ; does not seem to be ‘Maximum Threads’ one for if i set it to 200 it does not free my ressources

Try passing in the timeout value as a dynamic parameter based upon a field you set in your flow or message. So while you are in the testing environment maybe something less than 4 hours. Is this a long running process? Make sure your message threads are not operating in serial mode but configured for parallel execution. This is set on the triggers. You can also set the number of that will execute in parallel there.

As long as there are messages in a queue, restarting the server or reloading a package is not going to get rid of them. Assuming they are persisted.



raising the number of threads finally sorted out my situation
in Settings Ressources i set Maximum Threads to 1000
on the trigger document store capacity of 200
+ process documents concurrently
+ maximum execution threads : 200

so far it’s working
thanks for your help !

and to answer the first question, there must be a non documented feature on publish and wait which is stopping the wait after couple of days for my running publishAndWait services finally disappeared

I have seen this too where the wait on some services will not end/disappear in IS. Restarting the server is the only solution. But my issue is that I am always sending a timeout value for the pub.sync:wait service.

Any thoughts on why these instances are still “running”? I am able to run my service again with success even with this on my Service Usage page:

pub.sync:wait (11)

Is it possible that if I shut down the Developer/Browser before the service is finished, it will get stuck like this?


When you are stepping thru a flow, it is always good to reset the flow before you leave that window or turn off your developer session. Click under Test/reset or the F9 key.