How to analyze webmethod thread dumps

tried to open the webmethod thread dumps in TDA and samurai but couldnt open, IBM analyzer gives error “cannot find any thread dump”. please suggest how to go about it.

@anjaligobari , can you please share what steps did you take for generating Thread dumps?

Hi Anjali,

in addition to Kalpesh´s answer:
Can you provide a snippet of the thread dump just be sure.

I am fine opening the Thread Dumps with Samurai by following the below steps (on Oracle Solaris SPARC):

  • kill -3 “pid”
  • After that, take a copy of the file where the thread dumps are written to and remove all data before and after the tread dumps
  • Additionally remove all prefix characters from the lines containing the thread dumps (I use Notepad++ with Column editing mode for this)
  • after doing so, Samurai should be able to read in the file and parse the thread dumps.

Regards,
Holger

Hi Holger,
not sure of how the dumps were generated as we were directly provided with the dumps to analyze by another team, while i check with them on how they generated. PFA the snippet of the thread dumps and also have attached the samurai snippet where the log was parsed but the thread dump tab dint open with analysis.

i tried to remove the first 5 lines as u suggested but still dint find the thread dump tab in samurai


samurai

Hi Anjali,

when there are several (consecutive) Thread Dumps in the log file it is easier what it is really part of the Thread Dump and what is IS internal overhead.

According to the first screenshot most likely only the first 3 lines should be removed.
Eventually the forth line can be removed as well.

Regards,
Holger

Hi Holger,

tried removing 3 and then 4 lines but still the issue persists, any other analyzer tool that you would suggest?

Thanks
Anjali

@Kalpesh_Shah1 , can u please guide and suggest something?

Hi @anjaligobari ,
From the attached thread dumps , it looks like that it was generated from IS Admin UI , by navigating to Statistics → System Threads → Generate JVM Thread Dump as apparent from the breadcrumbs in the first 3 lines.
As Holger has suggested, the actual thread dumps start from line 4.
The next two lines aren’t important though , since they only indicate who generated the thread dump( line 4) , and time of generation (line 5) ,
Line 6 too can be ignored( empty line).

The problem seems to be at line 14 , which shouldn’t be an empty line, lines 7 to 18 denote information about a particular thread “process reaper” , you can try removing that empty line, or find out if there was a line accidentally deleted and pass this data to a analyzer tool.

-NP