how to add nonce to usernameToken for soap

Hello Everyone,

I’m trying to make a soap call to a primavera server on the same network using the consumer I have and my problem is that when I send the request using WM comparing the java demo given to me, there are “Nonce” & “Created” fields missing from my envelop in payload and for such reason I get 401 unauthorized response.

So what I’m trying to do is to somehow include those missing fields into my request header but on administration panel (localhost:5555) I couldn’t find any configuration section regarding this matter under webservice section.

Any help would be appreciated.


Hi Arash,

this cannot be done with administrative settings.

You will have to do so inside your consumer implementation (where the soap data is constructed).

Please refer to the WebServices Developers Guide as well as the IS Build-In-Services Guide for further informations.