How do I set the permission mode of files written by an IO adapter

On our system (Solaris), when an IO adapter on writes a file, the permission mode is ‘-rw-------’, and we need it to be different. We run the adapter and broker monitors (4.6 and 6.0 respectively) as root and have added ‘umask 0000’ to the adapter monitor start up script, but this has not had the desired affect.

How can I specify the permission mode of the files written by IO adapters?

If this is an Enterpise Adapter, try un-checking the “Enable Script Security” property. It’s found on the Java tab of the Adapter Configuration Tool.


The “Enable Script Security” has been disabled from the beginning (because it caused some other problems).

Thanks for the input though.

We got through to webMethods and found that there were some other umask commands in scripts. Once we commented those out, the file permission modes were as expected.