How do I repair a corrupted broker

To make a long story short, I corrupted my default broker, Broker #1. I know that there is something wrong because when I try to connect to it using EI, an error mesage is returned that says:

“Unable to open connection to host ‘MYHOST’. Error ‘java.net.ConnectException: Connection refused: connect’ was reported by the socket call”

Next, a fatal error message pops up indicating that the awbroker.exe program has shut down.

I was able to create a new broker named “BROKER2” and successfully connected to it using the EI tool so I know that my server is not completely hosed, but I am curious why these problems are occuring with my default broker (for which I have no backup…).

By the way, my specs are:

Enterprise 5.0
Windows NT
Lots of memory

Well, I solved the first problem. I started my Enterprise Server on the proper port. Heh-heh…

But, I am still seeing that second error:

[begin error]
awbroker.exe - Application Error: The instruction at “0x78001c9d” reference memory at “0x000000000”. The memory could not be “read”.

Click on OK to terminate the application.
[end error]

Thanks for your thoughts…

Okay, more news to report:

I went to the webMethods Advantage site to look for more answers and I came across the Enterprise 5.0 Service Pack 1.

Now, me and this service pack go way back. In fact, it was the last piece of software that I installed before I hosed my setup the last time so I was understandibly a little nervous about extracting it to the Enterprise 5.0 director. I installed it anyway and now I seem to have my broker back with all of its configured adapters and component scripts.

SIDE NOTE: The last time I grabbed the sevice pack, I forgot to stop the Enterprise Server for the installation. Think that made a difference…? :wink:

More on the Enterprise 5.0 SP1. The official service pack documentation states that the following issues are addressed:

Trax:1-5DQX8 Get error “Connection Closed (103-1070)…” when calling BrokerClient.getEvent(msec) in a multi-thread Java application.

Trax:1-5C4FP Broker Server stops when client group’s canpublish/cansubscribe lists are fetched.

Trax:1-553QN Broker runs out of address space on Windows.

Trax:1-5G415 Broker Server large allocation failes.

Trax:1-59OE9 Cannot create client groups after a combination of delete client group/clients followed by a create operation.

Trax:1-5AS7L Envelope field “_env.pubId” corrupted on events published across gateways.

Trax:1-5CQ4R Monitor does not display the flow of events for event retrievals.

I am not sure where my problem fits in to this list, but maybe on the second point about fetching canpublish/cansubscribe lists? Did I experience an unidentified issue which the service pack remedies?

Anyway, I didn’t mean for this to be a public debugging exercise, but hopefully somebody else will get value out of my experience.

I am not able to connect to my default broker. I have tried almost all the possible ports.
Can somebody please tell how to create a new broker using EI or any other tool.

Use the manager tool (WebMethods Enterprise Manager), select your broker server, then choose File - New - Broker…

Honestly i am a little worried by the question, it is a bit non sequitor. It sounds like you should read the wM manuals (e.g. Administrator’s Manual) real soon!

Good Luck!
-greg

This could be an :

  • XP problem…
  • Pentium 4 problem…
  • Service Pack problem…

webMethods support can help you with this one, that’s for sure.

FKATSD Shyam
~Formal Known As Technical Support Dude~

You might need to install the latest patch (no 8) in order to avoid corruptions of storage area. According to the Readme-notes of that patch it fixes lots of the issues that cause broker crash. I’ve had experience of some of them.

Before add a new broker, rename Broker.qs.log and Broker.qs.stor1 in C:\webMethods\EnterpriseServer5\data\awbrokers50\default to let it regenerate the file

This would make you lose all your documents, I’ve to say that. Secondly removing the broker-pers/broker.guar has the exact same effect for the 4.1.1 version…

hi ,
the following is the error i am getting when i am publishing the document on to the broker. I tried the same package in other IS, and it worked fine. But in my server , the below error is coming. Can any one tell me what is the problem and what may be the solution???

Could not run ‘publish_service’.

com.wm.app.b2b.server.ServiceException: [ISS.0098.9014] BrokerException: No Permission (109-1374): Cannot publish the document. Permission is denied. Check the ‘can publish’ permissions in the client’s client group.

Thanks and regards
ram

RamaKrishna,

Make sure that publishable documents have can publish permissions.

Look in the configuration of WmBrokerAdmin package home webpage.(http://wmserver:5555/WmBrokerAdmin/)

And see under the clientgroups whether this document have Can Publish permissions on the locak IS/Broker or remote Broker (if you are publishing to Broker connected using territory)

HTH,