How do I enable remote shutdown and restart of webMethods 8.2 Integration Server?

Definitely there is an issue either with master password or outbound passwords at startup, which is automatically place your IS in safe mode. If you don’t have issue with above, please share your just to make sure if someone modified it to customize.


If the issue was simply with the master password, then the server should always start in safe mode. Surbhi is saying it only starts in safe mode when he tries to start it from a remote server via ssh. Perhaps it is a permissions issue, i.e. the user who’s starting the IS does not have the necessary permissions to open the passwords file.

Surbhi, the syntax for the -l parameter is ssh -l (instead of @ ). I believe the two are equivalent but it doesn’t hurt to try. Also, can you check the permissions on the files and make sure the user you’re using in the ssh command has the necessary permissions?

When it comes to curl, if you want to restart the server, you would do something like:

curl -u Administrator:manage http://localhost:5555/invoke/wm.server.admin:shutdown?bounce=yes



I found a couple of references to your issue in Empower and it looks like a difference between the locale settings on the SSH client and on the remote server could lead to this issue. Can you check your locale settings?

Also, I suggest searching Empower for: ssh “master password”



you can try the following sample:

This allows to remotely shutdown or restart the IS (address and other parametes are stored in a simple properties file) by using a Java call to the shutdown service which already has been mentioned in this thread.

I have used this tool up to wM 7.1 as there was no available.

Thanks to Igor Androsov for the great work.