Help = JDBC connection from UNIX-based wM server to W2K-base

Hi, all.

My experience with webMethods has been limited to W2K thus far - this is my first try at configuring it on UNIX (RedHat Linux, in this case).

I have an Oracle9i server on a W2K box, with an Oracle database I want to connect to from my Linux-hosted webMethods server.

I also have an instance of webMethods on the same W2K box, which is able to connect to this database correctly. This basically tells me that things are okay from the Oracle standpoint.

I have been trying to configure the Linux JDBC adapter identically to the W2K adapter. So far I have done the following:

-Placed into IntegrationServer/lib/jars and restarted the service
-Confirmed that I can telnet to port 1521 from the Linux box to the target Oracle box.

-Configured the JDBC adapter on the Linux box as follows:

Transaction Type: NO_TRANSACTION
DataSource Class: oracle.jdbc.pool.OracleDataSource
serverName: <Oracle Server’s IP>
user: sbndb
password: ******
databaseName: sbndb
portNumber: 1521
networkProtocol: TCP
Other Properties: drivertype=Thin

Connection Management Properties
Enable Connection Pooling true
Minimum Pool Size 1
Maximum Pool Size 10
Pool Increment Size 1
Block Timeout (msec) 1000
Expire Timeout (msec) 1000
Startup Retry Count 0
Startup Backoff Timeout (sec) 10

The error blurb I get back when connecting is:

[ART.118.5042] Adapter Runtime (Connection): Unable to enable connection resource Connection:Test_Oracle.
[ART.118.5036] Adapter Runtime (Connection): Unable to configure connection manager.
[ADA.1.204] Cannot connect to the database with DataSource class “oracle.jdbc.pool.OracleDataSource”.
Invalid Oracle URL specified: OracleDataSource.makeURL

I believe that it is finding the driver, because if I intentionally misspell the driver name (ie. ‘OracleDataSource1’), I get a ‘classnotfound’ error.

What I’m not clear on is whether I need to install any Oracle software components on this Linux box for all this to work: other postings in this forum have included suggestions of environment variables pointing to the TNSNAMES.ORA file, et cetera - I have not configured any of these, because I’m not clear if they’re necessary when using the thin driver.

Any wisdom out there?

Many thanks!


Doug Whittier


You definitely do not need to do anything with TNSNAMES.ORA to make the thin client work. In looking at your settings, the only think I notices is that you have:
Other Properties: drivertype=Thin

In my working configuration, for Other Properties, I have:
(note the lower case “t” in thin)
I tried changing that to an upper case “T” and got the same error you reported.
I suggest changing that to a lower case “t”

Beautiful - that worked.

I was sure I’d tried that previously, but oh well.