getting started with JMS 6.1

I installed JMS 6.1 using the wm installer, however, when I run the IS Administrator (after re-starting IS) I do not see JMS under the Adapters tab (only JDBC Adapter is visible). So, I am unable to configure a JMS connector.

Packages–>Management shows that the WmJMSAdapter package is indeed installed and enabled.

Did I miss a step in the installation process?

Hi,

did you install wM JMS Adapter 6.x?
If so there might be a problem loading some JMS classes (check Packages->Management, if the package has been partially loaded).
Did you try starting the JMSAdapters HomePage by clicking on the house in
Packages->Management?

If you did install Broker JMS Provider 6.1, make sure that you have installed JMS Administrator 6.1 FP1 as well. You will be able to configure JMS Destinations and Factories there.

Regards,
Holger

Hi,

After running the wM installer and installing JMS Adapter, we have to place some JMS.jar file in the webMethods_dir/common/lib. Please do it and try restarting the server, if you have missed the step. Please check the steps in the webMethods JMS Adapter Installation Guide Version 6.0.

Hope it works.

Thanks,
Radhika.

I see that I placed the jms.jar file in the wrong place. The problem went away after I placed it at
C:\webMethods61\IntegrationServer\lib\jars\jms.jar

Thanks for your help.

I am having trouble running the PointToPoint.java sample shown in Appendix C of the wM JMS Provider Programmer’ss Guide. The program boils down to this:

//1. create Properties structure
Properties props = new Properties();
//2. setup reference to resource file
FileInputStream fis = new File(“jndi.properties”);
//3. load jndi.properties into props
props.load(fis);
//4. create initial context
Context ctx = new InitialContext(props);
//5. lookup queue connection factory object
QueueConnectionFactory qcf = ctx.lookup(“QueueConnectionFactory1”);
etc…

My problem is at step 4. I don’t know what parameters to put into the jndi.properties resource file. I tried this:
java.naming.factory.initial=javax.jms.QueueConnectionFactory

Where the javax.jms.QueueConnectionFactory is in jms.jar (which is in my classpath). I get the following error:

javax.naming.NoInitialContextException:
Cannot instantiate class: javax.jms.QueueConnectionFactory.
Root exception is java.lang.InstantiationException: javax.jms.QueueConnectionFactory
at java.lang.Class.newInstance0(Class.java:291)
at java.lang.Class.newInstance(Class.java:259)
at javax.naming.spi.NamingManager.getInitialContext(NamingManager.java:649)
at javax.naming.InitialContext.getDefaultInitCtx(InitialContext.java:243)
at javax.naming.InitialContext.init(InitialContext.java:219)
at javax.naming.InitialContext.(InitialContext.java:195)
at PointToPoint.(PointToPoint.java:55)
at PointToPoint.main(PointToPoint.java:25)

Any suggestions?

I got past step 4 [ctx = new InitialContext(env)] by placing the following line in the jndi.properties file:
java.naming.factory.initial=com.sun.jndi.fscontext.RefFSContextFactory

I also downloaded the following jars from Sun and placed them in
[IS base]\IntegrationServer\lib\jars folder:
fscontext.jar
providerutil.jar

Now I am stuck on step 5 [ctx.lookup(“QueueConnectionFactory1”)] with this error:
Failed to lookup Queue Connection Factory object
javax.naming.NameNotFoundException: QueueConnectionFactory1
at com.sun.jndi.fscontext.RefFSContext.getObjectFromBindings(RefFSContext.java:400)
at com.sun.jndi.fscontext.RefFSContext.lookupObject(RefFSContext.java:327)
at com.sun.jndi.fscontext.RefFSContext.lookup(RefFSContext.java:146)
at com.sun.jndi.fscontext.FSContext.lookup(FSContext.java:127)
at javax.naming.InitialContext.lookup(InitialContext.java:347)
at PointToPoint.(PointToPoint.java:79)
at PointToPoint.main(PointToPoint.java:26)

I finally got the tutorial to work by configuring the following under WmJMSAdmin:
Initial Context Factory: com.wm.jms.naming.WmJmsNamingCtxFactory
Provider URL : wmjmsnaming://Broker #1@localhost:6849

Hi,
I installed JMS Adapter and when i start the IS Administrator I dont see the JMS Adapter under Adapter tab. I even placed the jms.jar file in the following folder:
webmethds_dir/common/lib. also placed it in the following folder wm_jmsAdapter_dir/lib/jars…but in vain.

Please suggest…

Hi,

plase check under Packages -> Management in the IS Admin, if the package has loading errors. If so, try to correct them and reload the package.

Another to look into might be the IS Server LogFile.

Try to place the jms.jar in the folder wm_jmsAdapter_dir/code/jars or the one of the locations suggested earlier in this thread.

Which version of the JMS Adapter are you using on which version of the IS?
Maybe you need a Fix for the JMS Adapter or the IS to get them working together.

Regards,
Holger