Get Vs Post

I am trying to post xml to one of our external vendors. They have provided us url, uid and pwd.

When we posted the xmls through http GET method, we got 200-ok response.

But when we tried to post using http POST, we are getting authorization denied error.

What could be wrong? Is there anything that needs to be done from my side or is it the vendor problem?

When you are doing POST, how are you setting the uid/pwd?

I am assuming that you are using pub.client:http


This is a secure https call to one of our vendors. Our vendor has provided certs.

We placed this certs under /opt/xxx/certs. I want to know whether there is any default directory
where these certs need to be located?

Also how do I set up the provided certs?

You need to provide with more info… what are you trying to achieve and what’s the issue you are facing…

I am assuming that your original issue of GET vs POST is resolved…

Let us know.

See the Integration Server Built-In Service’s guide for details on how to use the service. You will need to know where your server’s private key, server certificate and root CA certificate are stored as well as the intermediate cert provided by your partner.


My original issue of GET Vs Post is not resolved. We need to send xmls to our partners thru https. Vendor has provided certs and we have added them to Security > Certificates > Configure Client Certificates.

But when I use pub.client:http to send the xmls, I am getting “Authorization required”. I verified with the vendor that the url, uid and pwd that I am using are correct.

What could be the problem? Is it because of the location of cert? Should be place the cert and in particular IS location?

You haven’t yet done what is needed to set the certificate chain properly on outbound HTTPS posts. The client certs portion of IS Admin relates to how to map certs on inbound posts to IS users and does not affect outbound posts.

Read the information I referenced in my last post.


For what purposes did the Client provide you the certs?

If the Client is authenticating based on userid/pwd (and not cert based), you dont need to set certificates anywhere.

which brings me back to my original question to you… if GET is working and POST is not, how are you setting the userid/pwd in case of POST?

Also, please read what Mark said with emphasis. (it clarifies the situation where vendor is using certificate based authentication)

Client has provided us both uid/pwd and certs. We placed the certs in Security > Certificates > Configure Client Certificates.
Can you please point to the location in the docs where is says we have to use either uid/pwd or certs for posting
xmls through https.

I have used pub.flow:http and in that I have given uid and pwd in auth section and method as post and tried to connect and
I got “Authorization denied”. When I change method to “GET”, I got 200-ok, but our client didnot recieve xml.

This used to work for few months in QA. We created another machine and installed wM with same config as QA and moved
code to that. Now I am getting the above error in both QA and UAT. Our cert is going to expire by the end of this month.
Could this be a problem? What are the things that we need to check?

Regarding what Mark mentioned about “”–> we have only one cert and this is the default cert.
I don’t think we need to use the above flow service if we want the IS to use default cert. Do we?


Try use keyword search in this form on “Authorization denied” you will find some similar issue results.