[gelöst] NOP531CF2 - Trigraph

Hallo zusammen

falls einer vorhat CF2 zu NOP531 zeitnah einzuspielen, dem kann ich derzeit nur abraten. Ein neues Feature “JCL load trigraph translation” verdreht eine Vielzahl von Sonderzeichen, wenn die JCL von openSystem geladen wird.
Das Problem ist bei der Software AG bekannt und meines Wissens bereits bei dataport und hier bei uns im BayLfSt aufgetreten.

Ein angeblicher Prerequisit NR214CF2 ist nicht dokumentiert und für uns derzeit auch noch nicht verfügbar.

Wir bemühen uns euch hier auf dem Laufenden zu halten …

Guten Morgen,
eine kleine Ergänzung von uns. Solange man eine JCL benutzt in der man keine Symbolfunktionalität benutzt, könnte man Glück haben und der Job läuft mit dem gewünschtem Ergebnis.
Was absolut nicht Funktioniert, ist die Symbolersetzung zum Aktivierungszeitpunkt. Da in der Regel die verwendeten Fluchtzeichen zu diesen Sonderzeichen gehören. :oops:
Beispiel:

JCL:
echo ‘----- BEGINN ----’
echo ’ ^MEIN-TEXT ’ Symbolersetzung zur Aktivierung ^
echo’-------- ENDE -------’

JCL nach Aktivierung:
echo ‘----- BEGINN ----’
echo ’ ??‘MEIN-TEXT ’ Symbol wurde nicht ersetzt!!!
echo’-------- ENDE -------’

JCL Submit:
echo $$ > “$EOR_WORK/$NPR_EGN/0021600036/AV/TEST-JCLLX/00002/J001HALLO.sh.pid”
echo ‘----- BEGINN ----’

echo ’ ^MEIN-TEXT ’ Hier sollte „Hallo Welt“ stehen

echo’-------- ENDE -------’

NPR2142 hab ich mittlerweile über den Support/Logistics bekommen.
gleich mal auf einer Testmaschine SLES 9 64-bit installiert und ausprobiert

Jobs vom Typ JOB
kommen wieder richtig im System an
insoweit funktioniert die Trigraph-Ersetzung
schaut nur bescheiden aus, wenn man sich das aktive Netzwerk in der Charakter-Oberfläche anschaut (zumindest bei unserer Terminal-Emulation)

Jobs vom Typ DAT
hier kommen statt der Umlaute immer noch die Trigraph-Ersetzungen als Ergebnis an, was äußerst ungut ist, wenn man Steuerkarten mit Sonderzeichen schreiben muss …

Es gibt mittlerweile auch ein Modul über den Support, mit dem man das verursachende Modul ausschalten kann, das werde ich gleich mal ausprobieren und dann hier wieder berichten …

Hallo Ulli,
das ist ja o.k. Aber die Frage ist, muss das mit den Trigraphen überhaupt sein! :twisted:
Bei uns ist eigentlich alles o.k.
Die PIPE wird nur wenn ein Symbol vor der PIPE ersetzt wird gelöscht.

Torsten

Nach Rücksprache mit der Entwicklung / Schnatbaum ist die Trigraph-Geschichte ein Kundenwunsch (???); Frage ist ob der Wunsch richtig erfasst wurde.

Mit dem vom Support übersandten Modul läßt sich die Trigraph-Geschichte ausschalten. Herr Schnatbaum bastelt derzeit auch an einer Integration in die System-Defaults. Wir bekommen also einen Schalter, wo man das aktiviern muss, wenn man es denn haben will.

Dass man uns so ein elementares Feature (mehr oder weniger ungetestet) einfach so unterschiebt, wird sicher auch noch Gegenstand der Diskussion auf dem AK sein.

PS: Jobs vom Typ DAT und Trigraph wird noch untersucht …

Die Vorablösungen der Software AG wurden heute per INPL bei uns eingespielt. Erste Tests sehen gut aus. Jobs vom Typ DAT funktionieren fehlerfrei.


Hallo,

also ich kann persönlich nicht verstehen, dass ein FIX NOP531CF2 noch
im Empower als Download zur Verfügung steht, obwohl scheinbar offensichtlich ist, dass wenn man diesen FIX einspielt Probleme mit NOP bekommt.

Hätte ich nicht vorher ins Forum geschaut, hätten ich jetzt schon die ersten Fehlermeldungen erhalten.

Ich bin bis zum heutigen Zeitpunkt immer davon ausgegangen, dass die Software AG diese Programme testet, bevor diese an den Kunden herausgegeben werden!

Nimms mit nach Darmstadt Frank!

Zur Info, falls eine® in EMPOWER sucht:

zur Information!

Der Hotfix ist nun offiziell verfügbar: OP53108
CF2 bleibt fehlerhaft wie es ist veröffentlicht, der o.g. FIX wird in CF3 integriert.

KnowledgeBase-Info wird die nächsten Tage veröffentlicht.