Filepolling issue (file is not moved)

HI all,

i have ESB IS 9.12 in my company now.
in the last few months my filepolling ports like doing nothing.
status is enabled, but file did not move.
I mus disable the port and change some value in the configuration texbox the enable the port.
do you guys have the same issues? is it webmethods bugs or i miss some configurations?

thanks,

Hi Junedi,

Did this work earlier anytime, that you are saying it stopped working?

Check all the configurations related to file polling port like directory paths, file name pattern, polling interval, and associated service is properly integrated. I believe you would have done all this correctly but still worth re-checking.

Also sometimes the directory from where the file is getting polled is having relevant permissions and no file is opened on windows or any editor by any chance which is blocking this.

Also once you place the file check the IS logs for any information related to any error causing this issue.

Regards,
Firoz N

Hi Junedi,

Please attach File Polling port configuration screenshot here so that we can understand how it was setup.

Regards,
Rakesh Mandala

Hi Junedi,

Apart from what Firoz mentioned steps, also pls try if you can re-create that file polling configuration (mock up port close to the existing one on the same/similar IS installed base ) and test the setup again to see if you can find any discrepancies etc…part of troubleshooting your IS config.

HTH,
RMG

1 Like

Hi all,

I have the some problem with both of emailpolling and filepolling

this is my filepolling config.

This is emailpolling port.

thanks

Hi Junedi,

Just checking: Was this port configuration working before or when did it last worked successful polling? Also has any thing changed in the IS admin/service env side? Did reset the port isn’t fixed the issue?

BTW,what is your current IS version and fix levels please?

HTH,
RMG

Hi,

this an intermittent issue. it work’s but somehow suddenly it does not work anymore.
email polling did not try to login to our mailbox anymore. but polling status is enable.
i tried to disable and enable the port again, it did not work.
I must edit the configuration value like image
then enable again. then it works.
but i need to know why this things happened.
because we don’t have any information why and when this things happened.

IS : image

thanks.

Hi Junedi,

I guess the configuration of file polling and email ports are getting corrupted by some means which is making this as stale and not allowing them to do what they are intended for. Once you edit them and save them back, they are again going back to work but getting corrupted by some means.

As @rmg suggested, please create a sample file polling port, another one, and see if this issue happens for that too. To drill down the issue to file polling specific port or all ports. This way we should be able to analyze this issue.

Check all the OS and IS level changes performed past recent times which triggered this issue for the first time.

Regards,
Firoz N

@Junedi,

Please based on the above comments try those considerations and let us know the outcome!!

HTH
RMG