File Polling Issue

I am facing problem while reading data from File Polling port service Invoke
where as I have configure File Polling port in my IS 8.2.2 version

Error While running service “Error processing service: [FPL.0002.0004] Server Error: [ISS.0086.9167] stream is a required field”

Setup as follow for FilePolling Port:-
Package Name WmFlatFile (I have tried changing package name to WmRoot & wMPublic, no luck same error)
Monitoring Directory \IntegrationServer\userFtpRoot\filePolling\Monitoring
Working Directory (optional) unspecified
Completion Directory (optional) unspecified
Error Directory (optional) unspecified
File Name Filter (optional) unspecified
File Age (optional) (seconds) unspecified
Content Type (optional) unspecified (I have tried changing context type to flatFile & txt as well, no luck)
Allow Recursive Polling No
Enable Clustering No
Processing Service service:pollFFDataToFtp (invoking service written in custom folder)
File Polling Interval (seconds) 10
Log only when directory availability changes No
Directories are NFS mounted file system No
Cleanup Service (optional) unspecified
Cleanup At Startup Yes
Cleanup File Age (optional) (days) 7
Cleanup Interval (optional) (hours) 24
Maximum Number of Invocation Threads 1

Service steps:-
Input : ffdata (Object)

File name is txt format and It has simple delimiter Flat File data

1.pub.io.streamToByte
2.pub.string.byteToString
3.pub.flow.getTransportInfo
4.pub.flatFile.convertToValues

I have read several post on file polling but not able to figure out where I am missing.
Can you please suggest or point out the mistake in configuration ?

Thanks

Hi There,

The error which you are getting is due to issue in mapping/passing input to the services which you have listed down. Kindly cross verify once again and let us know if you still having the issues.

Thanks,

If the service input is ffdata or try ffData (oject) the stream mapping should work.

Also on the file polling port configuration did you set the content type as application/x-wmflatfile?

HTH,
RMG

@MR as173d
I have check my mapping it’s intact no issue with mapping or any correction required

@rmg
I have change Content Type (optional) application/x-wmflatfile in file polling port and tested again by placing PO.txt (a comma delimiter flat file file in monitoring directory it’s went to the error directory)

Error :-
[284]2014-07-22 12:46:59 IST [FF.0001.0033C] Error processing service: [FPL.0002.0004] Server Error: [ISS.0086.9167] stream is a required field
[283]2014-07-22 12:42:56 IST [FF.0001.0033C] Error processing service: [FPL.0002.0004] Server Error: [ISS.0086.9167] stream is a required field

My Flow service steps and mapping details

1.pub.io.streamToByte
ffdata(object)–> stream --> byte

2.pub.string.byteToString
byte --> String

3.pub.flow.getTransportInfo
no mapping here

4.pub.flatFile.convertToValues
String --> ffdata

Raj,

Kindly share your flow service here so that we can do needed corrections and update you.

Thanks,

@MR as173d

I have attached file polling configuration details and flow service screen shot for your reference.
Pls let me know where I am missing logic here

Actually your Service input should be object named ffdata not as ffData…(It’s a case sensitive to be noted)

Can you try it again please?

@ RMG @ MR as173d

I believe we are very close to resolve this issue BUT unfortunately I am unable to resolve my wM 8.2.2 server start and designer issue can it possible for you to have a look once
Any way I have started separate thread for same but still if you have soln for this can you please share same here

=======================================================================
Can some one help me to resolve this webMethods 8.2.2 integration server issue,I am facing trouble while starting wM server as well as designer in version 8.2.2

OS : Window 7 with 64 bit OS
Java version 1.7 (build 1.7.0_65-b20)

Error :- While starting wM 8.2.2 server
Changing working directory to “D:\webMethods82\IntegrationServer”
Windows version is 6.1.7601
Starting as an application using Java.
Error occurred during initialization of VM
Could not reserve enough space for object heap
Could not create the Java virtual machine.

Configuration for server :-
I didn’t set anything in server.bat file I m using by default values AS IT IS
set JAVA2_MEMSET=-Xms%JAVA_MIN_MEM% -Xmx%JAVA_MAX_MEM% -XX:MaxPermSize=%JAVA_MAX_PERM_SIZE% -Xrs

Designer Issue :-
Error While starting eclipse base designer 8.2.2 same error could not start or create JVM

configuration for designer eclipse.ini
D:\webMethods82\eclipse\v36 >
D:/webMethods82/jvm/jvm160_32/jre/bin/javaw.exe
-vmargs
-Xms512m
-Xmx2048m

DO I need to set anything in Xusage.txt while by the way I am using by default value AS IT IS.
D:\webMethods82\jvm\jvm160_32\jre\bin\server> Xusage.txt ?

@ rmg Thanks

Your absolutely correct by changing input parameter name from ffData to ffdata it’s work fine and file went to done directory basically I have copied input name ie ffData from pub.flatFile.convertToValue as I know that for file polling port mechanism we need to have a object with ffdata type but I don’t know it’s case sensitive.

Why it’s take so much time for me to resolve this Issue as a first step of a service is streamToByte so I am unable to debug code or capture data in pipeline any way if first step is getting failed then definitely there is no way to capture data right ?

I like to know Is there any way to capture data in pipeline when we have first step in code logic with stream To Byte ?

Glad to hear it resolved.

Yes you cannot save streams and the only way is to after your bytestostring step to check the pipeline ff content.

Also If you want to introspect other internal transport layer things use the getTransportInfo as the firs step and then savepipeline.

HTH,
RMG

@rmg

Thanks for quick reply it’s help and I am waiting for your reply.
I m following you from wmuser forum and we are glad that ur here in SAG tech community as well :slight_smile:

Yes indeed and our wM saga should continue on . :smiley: