File Poll incoming directory

I’m running File I/O adapter ver 4.2. and using an FilePoll operation in my integration.

I want to poll on a directory on my network like

When I set this up in EI 4.1 it dont work. No messages but nothing happened if I put a fil out on that directory. If I run the adapter in debug-mode it worked perfect.

Could anyone tell me whats the difference and help me how to setup the incoming directory correctly?

This is typically a permission problem. When you run an adapter in debug mode, it executes with the permission of the user you logged in as. When a adapter is running normally (non-debug) it run with the permissions of the adaptermonitor process. You need to ensure that the adaptermonitor process user account has permissions to read a network file (in other words, assign it an account in a domain on NT/Win2K - don’t use the default system account).


This is most likely a permissions issue. The adapter runs as a different user (you) when run in debug mode vs. when run under the adapter monitor process. Make sure the user that the adapter monitor process is running as has access to the desired directories.

We are running v4.1 also and have had a problem with literal strings in the Poll Direcotry field. We have found that it only works if you use forward slashes “/” to separte the fields rather than the backward slashes. It only applies when you are putting the literal string in that field. Try replacing all your backward slashes with forward slashes and see if that is any better.

Your solutions works really fine!!!
Thank you all