Export table Error into WMS, all buttons and async table are disbled after export table

hi every body,

i need some of your wisdom, i got a problem in a portlet aplication, my app just print data in an “async table” and also export that result into a CVS file from a Command Button. When i run the app into LOCAL SERVER (My webMethods Preview Server at localhost), all is good, the app works great, all buttons are fine, the data are fine and the file is fine.

But when i run the app into de WMS (http://ip.address:8585) and export data (click on command button) the two buttons of the app inmediadly show disabled. I don´t use javascript code on the app.

I attach a document where you can view some pic and code of my app hopping you can understand better the app.

The problem is just in the WMS, in the local server all is fine, why?, and how can i solve this error.

I hope you can help me.



Problema en tener botones activos.doc (1.43 MB)

You will want to add a Script Block control to the bottom of your CAF view that adds a javascript action listener to the export button that re-enables the button after the export action completes.

For example, the value of your script block control would look something like this:

Event.observe( window, 'load', function() {
CAF.model("#caf:cid['downloadButtonIdHere']}").addActionListener(function(id) {

Seem to have found an alternative approach to avoid the disabling of controls in the page.

In case where we use a command link or command button to execute the file download, setting the ‘target’ property under ‘expert’ properties to _self will avoid the controls from getting disabled.