Error wile doing HTTPS post


I am trying to do a https post through the built in svc pub.client.http.
I am getting the error “Authorization required, Unauthorized”.
I am using correct user name and pwd only in the svc.
Could you please advise me here.

Alo, I am trying to use pub.clent.http svc to do https posting using ssl handshake and I read from documentation that below steps would suffice. Could you please let me know if the below three steps alone suffices for https post using ssl handshake (assuming certs are inatalled at both end)


Did you make sure the URL works with user/pwd authentication via browser just a test and nothing blocking both ends?


This service sequence is used to map your certificate to issue a http call ( as you might have noticed it requires private key) so if you are invoking any https url, place the clients certificate into your trusted store and just use the pub.client.http service with params in URL “https://XXXX” and user credentials… it shd be fine.

Note: Assuming there is no firewall in your systems and your called party’s environment which filter the HTTP requests. If there is any you need to include your IP’s in the allow list.

hope it helps!


Thanks for the reply… and apologies for getting back to u lately.

i tried opening the url in the browse but I couldnt (page cannot be displayed)… may be some settings needs to be done, as I connect to client network remotely.

Hi Dev expert :slight_smile: ,

Thanks for confirming the approach for SSL handshakein https.

I wonder, why I am not able to connect to the https site with basic authentication, which I could a few days back.

Also, I found a strange behaviour.

couple of days back, I could connect to the https url with pub.client:http even w/o user name pwd.

I guess this may be due to caching at some place.

And now, I could not connect to htps url even with user name/pwd.

while I dig in more, your expertise is most welcome. :slight_smile:


“couple of days back, I could connect to the https url with pub.client:http even w/o user name pwd” -->How did you tried this via browser or developer http service call?

What were the errors during could not connect attempt?



Cou[ple of days back, I tried through developer/pub.client:http svc with basic auth (username/pwd). Strangely it worked even with wrong user name pwd.

Now, the error I am facing even with correct user name/pwd is “Authorisation required, Unauthorised”

Basic auth with (Administrator/manage)? Did you also checked with ntwk teams on this issue if any firewall IP blocking happening both sites?