Error when running a query against oracle db

I’m making a service from the IS, which runs a simple select from 3 tables, but when i run this service i get the error:
[B2BCORE.0064.9314] Authorization Required:
[B2BSERV.0084.9004] Access Denied

The most weird thing is that when i trace or step into the service it works fine, but just when i run the service it fails.

Anyone could tell me what’s happening.

Thanks in advance.


The reason you can step through the service without that failure is that you have logged on to the Developer and the service is using your userid/password for authentication.

How are you running your service when you get the authentication error? Check to see what ACL applies to the service you have written. If you have not explicity set one, the service inherits the ACL of the interface it is under. If the userid/password that is used to run the service outside of the Developer is in a group that does not have rights to the ACL that your service is tied to, you won’t be able to run it. For example, if your service has an ACL of Internal and the userid that authenticates to B2B to run the service is in the TNPartners group, it will fail with access denied.

We are running the service from the Developer too.
The ACL that the service has is “” ,Do you think that this could be the cause of this issue? , because we was working perfectly until yesterday.

One thing that we just realized today is that if we call the query service from another service it works with no errors , but if the query service is runnig alone like yesterday it fails.

Thanks for you help.