Error using Datatype xs:Date

I’m using X-Node to connect to Microsoft Access. The schema can be defined successfully and processing xml document was fine when all datatype using xs:string. But when i try to use xs:Date, i received this error when processing the xml document:

<?xml version="1.0" encoding="iso-8859-1" ?>
- <ino:response xmlns:ino=“http://namespaces.softwareag.com/tamino/response2” xmlns:xql=“http://metalab.unc.edu/xql/”>
- <ino:message ino:returnvalue=“0”>
ino:messagelinedocument processing started</ino:messageline>
</ino:message>
- <ino:message ino:returnvalue=“8505”>
<ino:messagetext ino:code=“INOXME8505”>ODBC error occurred</ino:messagetext>
ino:messagelineLine 2, Column 1: State: 42000Native Error: -3100 [Microsoft][ODBC Microsoft Access Driver] Syntax error (missing operator) in query expression ‘ts’1982-09-19’}’.</ino:messageline>
</ino:message>
</ino:response>

In this case, my database i didn’t specify any condition or any format for the date datatype.

The format i’m using is yyyy-mm-dd. I tried changing to dd-mm-yyyy format but it prompts an error too. So for the datatype xs:date, which is th right format?? and for the above error, can somebody advise me on this…

thanks! :confused:

I found out myself that xs:Date is not supported in the current version…

I refer to this forum posted in Tamino Schema:
http://tamino.forums.softwareag.com/viewtopic.php?p=11736

In that topic I mean that xs:date is not now supported for indexing, but you can create elements and attributes of xs:date type and link them to RDBMS fields. I tried that with MS SQL Server, though I experienced some problems. For instance, when I mapped xs:date element to TimeStamp field, result xml document contained date and time, that violates my schema a bit.

I didn’t try Access, so I unfortunately can’t help you here. Sorry