Error starting broker monitor

hi i installed the broker monitor and broker server 7.1

when i tried starting the monitor from the services received the following error.

Could not start the webmethods broker server 7.1 (6849) service on the local computer.
Error 1075: the dependency service does not exist or has been marked for deletion.

i received the following error while creating the broker server

com.wm.installer.broker.ConfigurationException: An error occured while creating the default broker.

Unable to find host ‘null’ on the network.

please help

Praveen

Hi Praveen,

Not sure about this error but try this out if nothing works out :

  1. Install broker as an application and not an windows service
  2. Start broker monitor and broker server manually

If I get anything on this error will let you know.

Regards,
Sumit

i have already installed the broker as application and not as service… n now i am even unable to reinstall the broker server it says already exists…

Praveen

Just a little check, while installing broker did you miss giving machine IP

There is one option in installer : “Replace corrup installation files, including user data”.
If you have not tried this , try this to reinstall broker.

hi

i tried the reinstallation of broker with replace corrup option but still it didnt work out…

i am receiving the following errors while reinstalling the broker

com.wm.installer.broker.ConfigurationException:

[BRC.200.1170] Error: Cannot create new Broker Server as NT service “webMethodsBroker_7.1_6849”: The specified service already exists.
[BRC.200.1085] Error: Could not create new service “webMethodsBroker_7.1_6849” from Service Control Manager: The specified service already exists.
[BRC.200.1160] Warning: Cannot make a connection to the local Broker Server Monitor:
Broker Not Running (101-1020): The host ‘’ was found, but no Broker Server is running on port 6850 on that host.

[BRC.200.1098] Warning: Could not signal Broker Server Monitor to reread configuration.

on pressing ok

then “cannot start broker” msg.

then…

com.wm.installer.broker.ConfigurationException: An error occured while creating the default broker.

Unable to find host ‘null’ on the network.

these are the error msgs i m getting on reinstalling the broker one after another…

please help
Praveen

Use the command netstat-a and find if the port is already in use or not.

Also rename the default dir “\webMethods7.1\Broker\data\awbrokers71\default” and try.

If nothing is working, try to use some other port and use it.

Warm Regards,
Gopinath K.M

no gopi nothing is working the folder is already the same wht you specified also tried changing the port but still getting the same exception

Praveen

Try uninstalling the broker server and restart the system. Delete or rename the broker folder and then install it freshly. Sorry no idea .

May be you can try with the command line tools available under “\webMethods7.1\Broker\bin”

Before reinstalling once, it may help you