Error in configuring the JMS adapter in the admin page

Hi
I am new to JMS adapter.
We are trying to configure a new connection for a JMS adapter.
We have imported the wMJMS Adapter package at first place.
We created an environment, Provider, Connection Factory( for Topic ) and the Destination in MWS.
Now in the admin page, we tried to configure the new connection for topic but we could not succeed.
We are getting the following error when we tried to enable the connection.

Error encountered
[ART.118.5042] Adapter Runtime (Connection): Unable to enable connection resource NAIP_Connections.JMS:TopicConn.
[ART.118.5063] Adapter Runtime (Connection): Unable to start connection NAIP_Connections.JMS:TopicConn: after 1 attempt(s).
[ART.118.5036] Adapter Runtime (Connection): Unable to configure connection manager.
[ADA.680.201] Cannot connect to the JNDI Provider: “wmjmsnaming://jmsbroker@saenad20:7250/NAIP_JMS_TEST”.
Cannot instantiate class: com.webmethods.jms.naming.WmJmsNamingCtxFactory

Can anybody give inputs on this to solve it.

Thanks
Krithiga M

Hi Krithiga M,

Please provide the version of webMethods, JMS adapter abd broker you are currently using at the moment.

Best Regards,
William Choong

Hi Krithiga,

Please check at your end whether you have set up the settings appropriately :

  1. Is your Connection Factory is properly binded to the JNDI?
  2. Is the required client (jar) files were loaded by the IS? (You can check that in the IS ‘about’ page)
  3. Have you applied the latest JMS Adapter fix?

Best Regards,
William Choong

Hi William,
Thanks for your replies.
This problem is solved for me…
I was not aware of the concepts in the beginning,.
I was trying to do this in webMethods 8.0.
There is no JMS adapter in webM 8.0.

So, we tried configuring everything in admin page itself.

Thanks again,
Krithiga M

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.