Error: Failed to create JVM during initialization because &

We received this error after installing and attempting to start WM IS 6.0.1 on a W2K server.

Check a couple of things on your installation:

  1. Open \IntegrationServer\bin\server.bat and check for the line:

SET JAVA_DIR=\IntegrationServer\jvm

This sets the path to the bundled JVM, which the IS will use by default.

  1. Use windows explorer to check that the bundled JVM is actually there, i.e., the directory tree should look something like:

\jvm\win.sun13…with the usual Java dirs below this (bin, lib, jre, etc).

  1. Open a command prompt and navigate to \jvm\win.sun13\bin and check the version of the JVM by typing java -version. It should show the java version.

If any of these fail, you probably have a corrupt install. I would reinstall the IS.

  1. Although I’m not sure this is required, check your environment variables for the CLASSPATH variable, and add \IntegrationServer\lib to the front. Try rtestarting the IS.

Hope this helps,
-Zia

Zia,

Thanks a lot for the suggestion. I do appreciate it. I’ll let you know how it works out. It seems several other members have experienced the same problem, so I’ll send your suggestion out to them if successful.

Thanks again!

  • Scott

WM IS 6.01 SP2 and WM IS Fix 24 overwrite the server.bat and server.sh. And if I remember correctly, the JAVA_DIR variable of the new server.bat contains a dummy value. Maybe that’s causing this trouble.

All…

Thanks for the suggestions. We tried them all, and also had to remove a lockfile from our integration server directory. Things are working great now. Below is a note from my NT Server support person that may help anyone else who may be experiencing this problem.

“Well, there was a LOCKFILE left in the integration server directory. Apparently a LOCKFILE is created when the Integration server is running and deleted when it is stopped. However, sometimes if the server isn’t shutdown properly, the LOCKFILE remains behind which prevents you from starting the integration server. So, I went in and deleted that file and was then able to start the integration server service. But, then I was unable to start the “WebMethods Broker Server 6.0, port 6849” service. To resolve that, support had me rename broker.qs to broker.qs.old in the S:\Sysapps\webMethods6\Broker\data\awbrokers60\default directory. And, this corrected that issue.”

Thanks a lot for the help!!

  • Scott

I tried all of above, but still got the same error.

So I defined my environment variables “CLASSPATH” to be “.”, then unregister and register the service (%IS%/support/win32/installsvc reg) again. And it’s started now.

=Rawich=

We ran into this same issue. and figured out that the domain account which we used to run under for the NT Svc, was not part of the Admins and hence when tried starting the service, it was not able to add entries into the registry. By adding the domain account into the admins, fixed our issue.