Error deploying microservice using Bitbucket docker version 25

Product/components used and version/fix level:

Cumulocity IoT 1019.22.0

Detailed explanation of the problem:

We are creating microservices docker images using docker on pipeline runners in bitbucket (image: node:20). Those use a newer version of Docker (version 25) than was previously supported by Cumulocity. The error message you got then was something about Layers that was not supported. That problem is supposed to be fixed but now we get a different error when trying to upload the zip file. We have tried uploading the file manually and through the REST API with the same result. When packaging the microservice locally using Docker v24 it works normally just like before.

Error messages / full error message screenshot / log file:

“Push failed on image : Config file does not .json extension”

Hi @MagnusAkermanAspire

it is a know issue which is fixed in the upcoming versions.
Unfortunately not for 1019.22.0. You have to wait until your instance is upgraded to 1020.383.0 at least.

1 Like