Error creating Property in Eclipse 3.0 with wMPortal 6.5

Whenever try to create a property in Eclipse, it throws the following error:

Com.webmethods.portal.bizpolicy.BizException: [POP.001.0002] A “org.apache.axis.AxisFault” occured with the Message. “No such operation listpropertyeditors”.

I tried, restarting the portal, installing the wmPropertyeditors component. but still facing the same problem.

Kindly let me know how to solve this issue.

Regards,
Rakesh

What user account are you using to connect to the portal?

I am using the portaladmin account to connect with the portal through Eclipse.

You did mention in the original posting that you have deployed wmPropertyEditors component. Could you please reconfirm what was the name of component file you have deployed.

For the design time operations to work you need to deploy components\development\eclipse\wm_pghelpers.pdp component

Might as well start at the bottom and work up.

  1. Is the ‘ListPropertyEditors’ command deployed?
    a) As the portaladmin user, navigate to ‘http://[host:port]/folder.command’.
    b) Drill into the ‘developer’ subfolder.
    c) Verify if there is a resource named ‘listpropertyeditors’ in the subfolder.
    d) If there is a resource with that name, click on it and verify that the ‘Enabled’ property is set to true.

  2. Is the command available to execute as a webservice?
    a) As the portaladmin user, navigate to ‘http://[host:port]/services/command/listpropertyeditors?method=listpropertyeditors’ and verify that that URL returns a big XML file.

If any of the above conditions are not as expected, let us know.

Yes both the conditions you have mentioned above is working fine. But still I am getting the same error.

Do the portal server logs contain any additional information about the error? Perhaps the full stack trace?

I dont see any error in the portal server log.

Even I dont think that, it will log any error as this error is occuring in Eclipse while creating a property for a portlet. Portal server log will log a message only if it throws any error while or after deploying the portal.

Actually, the portlet property dialog makes a webservice request to your portal server to retrieve the information about the portlet property editors that are deployed on your target portal server. That webservice request seems to be the cause of the error message you are seeing.

Since all the conditions I outlined earlier seemed to be working normally, I can not think of any obvious reasons why it would not work.

I’d suggest opening up a support issue with tech support.