Error accessing wmPRT package while deploying the BPM process

Hi All,

Getting the below exceptions while build and uploading the BPM process for exceution.

Have configured the Integration server and Process Audit Database as well, but still getting the below issue :frowning:

Could anybody please let me know the probable solution for the same.
Thanks a ton in advance !!!

Hi there,

Have you tried reloading the WmPRT package before building and uploading the process? Is the package showing up as enabled?

Also, which versions of Designer Process Development and Process Engine are you using? Do they match?

Hi Prateek,
Try few Things:

  1. Check home page of WmPRT–>Dashboard and see if all the icons are showing green. Not mandatory for “optimize logging” if urs is not a BAM environment.
    (2) Assuming above is correct, try reloading WmPRT package and then try build & upload.


Hi Micheal and Ranjay,

Thanks for your response.

Have tried to reload the wmPRT package, it gets reloaded successfully but again same error occurs.
I also checked the version of the clients and server, for clients (Designer/Developer) we are using 8.0 and for server (IS,Process Engine, Task Engine) we are using 8.2 in our local machines.
But then i also tried to deploy the same BPM to Dev environment which have webMethods all components on 8.2 version, there also got the same issue.

Also when i try to go to Home of WmPRT package from IS, a blank window gets open with no content in it, ideally it should have the contents of the same package.

I think that might be WmPRT package got corrupted any how (not sure how).
Is there any possibility that WmPRT package or any other WM internal packages got corrupted?
If yes then can we import the same package from other higher environments(QAT,UAT) ?

Hi Prateek,

Unfortunately, using 8.0 clients with 8.2 servers will not work for building process models.
The Designer BPM plugins must be at the same version as the WmPRT package and Integration Server.

If the WmPRT home page is not even coming up, it definitely appears as though you have a corrupt installation of that package. Would it be possible to uninstall and re-install from the SAG Installer? That may be a better bet than just importing the package from another environment.

Also, you’d want to make sure that your JDBC pools are set up properly with the Process Engine alias working, and the schema set up.

But please do ensure that your client/server versions match.

Best regards,

Hi Michael,

I have upgraded the process engine to 8.2, also checked the JDBC pooling its properly configured.
Build and uploaded the BPM it works fine now.

Thanks for your help :slight_smile: