Error 999 when using a loop

X-Application Version: 3.1.3
Tamino Version : 3.1.1
Platform : NT
WebContainer : Tomcat 3.3
JDK Version : 1.3.1


I let X-Application generate JSP’s, then modified structure.xml and regenerated the JSP’s. Who can tell me what is wrong with the loop at the end of the view-section? If it is activated, an error 999 occurs (see attached file).

Thanks a lot!

error999.rtf (4 KB)

Oh, sorry, I seem to have had a lack of concentration yesterday, I forgot to attach the modified structure.xml.
structure.xml (4.25 KB)


the error occurs because X-Application is a schema oriented framework. To iterate the nodes FBRAN and FBANT, the content of the element FOBJ is parsed according to the schema definition.

To find out the reason for this error we need your schema. I have one from a former request, but I don’t know whether it’s the current one or you made changes on it.

The schema we have is attached. Is this your current version?

Bye Christian.
fobj_schema.xml (11.4 KB)

Hi Christian,

here is the latest version of my schema.

The original reason for me to modify structure.xml was to try to find out, why my application crashes, if I try to display the elements 4-10 (FBEG, FBEGA and so on) in the next loop respectively FCHROGRD, FCHROGRDT and so on in the following one.

After deleting these displays, the problem with the first loop appeared, which had never caused trouble before.

Fobj.tsd (11.1 KB)

I analyzed your schema, it is ambiguous …

Consider this schema fragment (given in DTD notation because it’s shorter), which occurs at various locations in your schema:

And a valid document:

What would you expect to see on X-Application’s view page for this document?

1) a list with one item, and the item contains both elements “a” and “b”.


2) a list with two items, the first item contains element “a”, the second item contains “b”.

X-Application cannot automatically determin which of the possible view pages is correct.

To solve this problem, I suggest changing your schema: make sure, that every “unbound” sequence contains at least one mandatory element. Example: the above schema fragment could be changed to

This subject is quite difficult and I’m not sure if this is enough to explain it. Don’t bother to ask back!


Software AG Germany, Darmstadt

Hi Christian, hi Michael,

thank you, it works!

But what I don’t understand is, why some elements in a sequence must be defined mandatory, and some do not need this definition. If you have a look at the attached version of my TSD-File, you will see, that the elements FBEG and FENDE have minOccurs=0. If I try to define one of the other elements in the same way, for example FBEGA, again error 999 occurs.

What is my mistake?

Thank you!

Fobj.tsd (10.7 KB)

Here is the error report…
error.rtf (2.74 KB)

Hi Gerald,

I tried to reproduce the problem but I didn’t succeed. I generated an application for your schema, and fixed the loop names in the resulting create.jsp file. I open the create page in my browser and tried every “add” button - it work!

Could you please supply some more details how to reproduce this problem?


Software AG Germany, Darmstadt