Error 053 for the record buffer

Hello,

Getting response 53 for record buffer,
suggested action is “Increase the record buffer size”.
How to Increase the record buffer size?
(Solaris, ADABAS 6.3.1)

Thank you
Boris

Are you using Natural or issuing direct calls?

Could we see your Format Buffer, and the definitions of the fields in the Format Buffer.

Ralph, Steve, Thank you for your attention to my post.
I understood that I should clarify my question.

Error 3053 is not a major reason for question b/c I have a simple way to handle it - just removing excessive fields/occurrences from the VIEW (call made from Natural).

My question was triggered by the following response from SAG support regarding error 3053:

“Under Natural it is the datsize that I think is causing your restriction. The datsize is a dynamic variable to you can try executing you Natural Transaction with DATSIZE=128 the default is 32K but will be increased when needed depending on the thread environment. But the easiest way to check this is with an override when executing Natural.”

From this response I derived that:

  1. DATSIZE is a part of configuration available at Unix Open System.
  2. DATSIZE is a dynamic parameter for Natural.

If statements above would be correct it would be possible temporarily fix issue 3053 without changing source.
But experiments shows that or statements are false or documentation is incomplete or I’m doing something wrong.

Probably the correct question should be:

Is it possible and how to maintain max size of the RECORD BUFFER?

Thank you,
Boris

PS.
Steve, how nice to meat you again!
I always enjoyed your posts and copy-paste from your examples without hesitation. javascript:emoticon(’:D’);