EnterpriseOne 6.2 Adapter BSFN Call Error

When the adapter attempts to invoke BSFN we get th following error

2006-09-28 10:30:25 CDT [ADA.7180.4011D] Creating OneWorldInterface for session “177944858”
2006-09-28 10:30:25 CDT [ADA.7180.4012D] OneWorldInterface created for session “177944858”
2006-09-28 10:30:25 CDT [ADA.7180.4004D] Start Transaction for sessionID “177944858”.
2006-09-28 10:30:25 CDT [ADA.7180.5015D] Beginning execution of BSFN: “X0010GetNextNumber”
2006-09-28 10:46:20 CDT [ART.0114.1007E] Adapter Runtime: Error Logged. See Error log for details. Error: [ART.117.4002] Adapter Runtime (Adapter Service): Unable to invoke adapter service BioScience.AdapterServices.BBRPO:BSFN_X0010GetNextNumber.
2006-09-28 10:50:14 CDT [ADA.7180.4005D] Commit Transaction for sessionID “177944858”.
2006-09-28 11:09:11 CDT [ISC.0076.0004W] BinCoder decode error creating as String java.lang.Long, s=180000. Excpt:java.lang.OutOfMemoryError

This is a simple BSFN to get nextNumber and gives us some BinCode error?
I have copied the Connector.jar files from OW server to IS server as well and still get the same error.

Any help will be appreciated.

For one there seems to be an error generated with out of memory. A little more info thats in the error log would be helpful to understand why it has caused and where it has caused.

The error occurs when trying to execute the BSFN. I pasted the error form server log directly in my post.

Note, after we see this, the entire IS hangs. We have to restart IS.

In fact, I find this Adapter SUCKS! JDE/Peoplesoft have done a poor job in QA of this adapter.

I wonder how many people are running the EnterpriseOne 6.x adapter in production?

It is always a good idea to review the “Service Packs” and “Fixes To Known Issues” sections of the Bookshelf on Advantage to determine whether any service packs or fixes exist and need to be applied.

The adapter version you are using appears to have at least one available fix “webMethods Peoplesoft EnterpriseOne Adapter 6.2 Fix 1”.

There are many potential causes for out-of-memory errors including improper IS configuration settings, excessive server load and poor coding techniques. While it is certainly possible that this adapter version has defects affecting performance or memory use, I don’t think you can jump to the “it sucks” conclusion so quickly.

What version of IS are you using? What service packs and fixes have you applied to that version? What are the min and max memory settings in your server.bat/sh script?


Fix1 for this adapter is already applied. IS fixes are all applied.
Its a simple test flow which is calling a BSFN which returns next number so I don’t think its a coding issue.

We are just testing if we can use this adapter and it can perform smoothly…hence the ‘it sucks’ designation.

It hangs our IS, when it tries to create a connection to OneWorldXE from its connection pool.

Is your PSFT server accessible (pingable) from the IS box? How is the connection pool configured? I assume the adapter connection can be enabled successfully? You can crank up logging verbosity for the “facility” for that adapter to get a better idea of what is going on.



Have done all that (ping, verbose logging etc).

Its only when it cannot connect or invoke a BSFN that the adapter hangs and also hangs IS. That seems a memory leak/bad code/no QA issue to me.

Does not seem the timeout value in adapter settings have any effect since the hanging thread, hangs everything else.

And what do the good folks at WM Support have to say on the matter? Be sure to escalate past the first levels and get this issue into the hands of the appropriate adapter product development folks.


We had some issues with EnterpriseOne adapter early this year (not as same as yours), and the problem solved after upgrading the tools release in EnterpriseOne server.
May be you should look that side too.


Hi all,

wM support contacted Peoplesoft support. Peoplesoft provided a new .class file called ERP8ConnectionFactory.class which solved the problem.

Apparently their original connectionFactory had a memory leak.


Excellent! Thanks for providing the update.