Enterprise Server Configuration

I’m getting the following error when I run the broker monitor… The enterprise server is installed on default port:6849.

Error: #1023 Cannot bind main socket to port 6850: Address already in use – Another Enterprise Server may be running already. – [EXITING]

I tried to list the enterprise servers installed on the host using broker_config program. But I get the following warnings,

Warning: Cannot make a connection to the Enterprise server monitor on “localhost”:(101-1020): The host ‘localhost’ was found, but no Enterprise server is running on port 6850 on that host.
Warning: Could not contact Enterprise server monitor for list of Enterprise servers.

Next it lists the local configuration on port 6849.

Any suggessions ?


Use a port x for ES for which port x+1 is free (under Win you can test free ports with netstat -a)

I think ES receives requests on port x and then handles out (with requestor) to switch to port x+1 for port x is free for subsequent requests.