enterprise integrator crashes constantly

Just installed the following in this order:

enterprise adapters 4.1.1
enterprise integrator 4.5.2 - EIAdapters
enterprise integrator 4.5.2 - ETools
enterprise integrator 4.5.2 - JVM 1.3
enterprise broker server 5.0
all applicable patches

enterprise integrator crashes constantly with java errors when working with configured operations. this seems to happen most often when switching from one operation to another. any ideas?

More info:

I’m running on windows 2000 sp2. I installed everything into c:\servers\wm_ent. Here’s the java error I’m getting:

Exception occurred during event dispatching:
java.lang.NoSuchMethodError
at COM.activesw.tools.tahoe.operation.configured.GenericPluginEditor.cleanUp(GenericPluginEditor.java:197)
at COM.activesw.tools.tahoe.operation.configured.PluginCard.cleanUp(PluginCard.java:81)
at COM.activesw.tools.tahoe.operation.configured.ConfiguredDeck.rebuildPluginCards(ConfiguredDeck.java:143)
at COM.activesw.tools.tahoe.operation.configured.ConfiguredDeck.edit(ConfiguredDeck.java:178)
at com.wm.ite.api.TitledEditor.edit(TitledEditor.java:252)
at com.wm.ite.api.DefaultApplication.showEditor(DefaultApplication.java:727)
at com.wm.ite.internal.EditedObjectManagerImpl.setEditedObject(EditedObjectManagerImpl.java:102)
at COM.activesw.tools.tahoe.model.TreeCard.setCurrentNode(TreeCard.java:261)
at COM.activesw.tools.tahoe.model.TreeCard.setCurrentNode(TreeCard.java:289)
at COM.activesw.tools.tahoe.model.TreeCard.setCurrentNode(TreeCard.java:293)
at COM.activesw.tools.tahoe.model.TreeCard$TreeCardHandler.valueChanged(TreeCard.java:489)
at javax.swing.tree.DefaultTreeSelectionModel.fireValueChanged(DefaultTreeSelectionModel.java:612)
at javax.swing.tree.DefaultTreeSelectionModel.notifyPathChange(DefaultTreeSelectionModel.java:1006)
at javax.swing.tree.DefaultTreeSelectionModel.setSelectionPaths(DefaultTreeSelectionModel.java:288)
at javax.swing.tree.DefaultTreeSelectionModel.setSelectionPath(DefaultTreeSelectionModel.java:171)
at javax.swing.JTree.setSelectionPath(JTree.java:1088)
at javax.swing.plaf.basic.BasicTreeUI.selectPathForEvent(BasicTreeUI.java:2117)
at javax.swing.plaf.basic.BasicTreeUI$MouseHandler.mousePressed(BasicTreeUI.java:2683)
at java.awt.Component.processMouseEvent(Component.java:3714)
at com.wm.ite.util.ActiveTreeWithPopup.processMouseEvent(ActiveTreeWithPopup.java:65)
at java.awt.Component.processEvent(Component.java:3546)
at java.awt.Container.processEvent(Container.java:1167)
at java.awt.Component.dispatchEventImpl(Component.java:2595)
at java.awt.Container.dispatchEventImpl(Container.java:1216)
at java.awt.Component.dispatchEvent(Component.java:2499)
at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:2458)
at java.awt.LightweightDispatcher.processMouseEvent(Container.java:2217)
at java.awt.LightweightDispatcher.dispatchEvent(Container.java:2132)
at java.awt.Container.dispatchEventImpl(Container.java:1203)
at java.awt.Window.dispatchEventImpl(Window.java:918)
at java.awt.Component.dispatchEvent(Component.java:2499)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:336)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:134)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:101)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:96)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:88)

The on-line Sun docs for NoSuchMethodError state:

"Thrown if an application tries to call a specified method of a class (either static or instance), and that class no longer has a definition of that method.

Normally, this error is caught by the compiler; this error can only occur at run time if the definition of a class has incompatibly changed."

Have you tried to install different versions of EI? Particularly an older one over a newer one? You might try a complete uninstall and a fresh install, though that’s a pain.

Double-check that you have the supported Java environment that’s specified in the install docs for the version you’re installing.

Rob

I’ve only installed the 4.5.2 version of EI and then the tools patch for 5.0 broker server.

I installed the jvm that was bundled with EI as well.

I just repeated the process from the beginning on a solaris box and am getting the same result. It seems strange that others aren’t experiencing the same problem.

This error is being generated because a critical file was not found in the installation directory. The file is installed by default, but can potentially be damaged or removed if an install or uninstall process is interrupted, or if the file has been manually altered or deleted.

After the appropriate backup / export of all work, completely uninstall Enterprise Integrator (including manually removing any directories that were not uninstalled by the uninstaller) and then reinstall Enterprise Integrator. This reinstall should solve the problem that you are seeing.

-David McJannet-
Product Manager, Enterprise Platform
webMethods, Inc