Enable Update Notificaction Error, S.O.S.

Hi everybody, im here again for some wisdom.

I have an adapter (update notification) in serverONE and it works perfectly, but when i try to install it in another server and i try to enable it in the serverTWO:5555 --> jbdc adapter --> notification i have an error with this message (in the serverTWO:

the way i install the package is:

  1. loggon serverONE:5555

  2. release package

  3. create release package

  4. select elements of the “update notification”

  5. create package release

  6. copy package release created in serverONE to the path …/integrationServer/Inbound/ of serverTWO

  7. loggon serverTWO:5555

  8. Manage packages

  9. Install package

  10. Select package release to install

  11. install

  12. serverTWO:5555 --> jbdc adapter --> notification --> eneable notification NameSpace:adapterUpdateNotification.

  13. ERROR

I must to say that the serverONE and serverTWO have same configurations: (same db name and tables, connection, flow services services) for the package that i want to install, obviously the conexion with different IPadress for de data base.

Can someone guide me to find why this error?
How can I fix it?

And another thing, when i try to install the same package in a serverTHREE this error never happend, and yes, serverTHREE has exactly the same configuration than serverONE and serverTWO

Please, I need wisdom, thx colleagues.

Hi Jorge,

I guess you are referring to a Polling Notification of the JDBC-Adapter?

Please check the following:

  • Fix Level of the IS Server (incl. ART) and JDBC-Adapter
  • Patch-Level of the Database(s)
  • Version of the ojdbc*.jar used by the JDBCAdapter

Make sure that the schemas in the different databases have enough rights (grants) to create and drop the required tables, sequences and triggers.

HTH,
Holger

Hi Jorge,

Can you please paste the error from server log / error log, so that we have more visibility about the issue?

Thanks,
Rankesh

Please make sure the server TWO has the exact same configuration as the ONE AND THREE…definetly something shows missing in the target db or the IS resource itself…you may also contact the target DBA as well on the ORA issue.

HTH,
RMG

Hello colleagues,

@Holger von Thomsen

All server have the same grants for all db objects for the same user “Administrator”

:shock: How can i do that? or where can i see the information?

i must say something… I’m a modest software developer, I don’t have too much knowledge as administrator, it’s hard to be perfect :frowning:

@Rankesh Kumar

That’s all the information in the log’s the other lines are from other app’s (packages) :?

@rmg

server ONE, TWO and THREE have the same configuration, i mean in JDBC connection, polling notification, data base name, table name, user, pass, i must say something, server one is “development”, server three “test”, server two “production”.

I can’t release my development :cry:

You may have to check more in your production env what piece is missing source IS or target DB side before you enable the notification objects and the mentioned checks from the other users.

HTH,
RMG

@Jorge,

You can get details using expand stack trace checkbox on error logs page.

I found similar thread on tech community, which may help you to resolve your issue. Please check the following:

http://tech.forums.softwareag.com/techjforum/posts/list/18769.page

HTH.

Thanks,
Rankesh

Hi did u copy class14.jar file in in u r servers c:/softwareag/Integration server/lib/jar
u need download and copy the class14.jar file in above path an restart u r server hope its gonna work pls update me .

Hi,

you can find the Version of your IS´s as well as the patches by using these URLs in the Browser:

http://server:5555/WmRoot/about.dsp
http://server:5555/WmRoot/updates.dsp

Are you doing service development by using Developer (deprecated since wM 8.2.x and has been removed in wM 9.x+) or Designer (recommended for wM 8.2.x resp. required for wM 9.x+)?

For the database parts you should ask your database team.

Depending on the IS-Version (and therefor the used JVM) and the Dtabase version there are several different driver jars for Oracle DBs (these can be downloaded for free from Oracle Technology Network [free registration required]):

JVM 1.5: ojdbc5.jar
JVM 1.6: ojdbc6.jar
JVM 1.7: ojdbc6.jar (for Oracle 11g and before)
ojdbc7.jar (for Oracle 12c and newer)

These jars are backwards compatible down to Oracle 9i R2 for those running on an old database.

For Oracle Database driver it is sufficient to place the jar in IntegrationServer/packages/WmJDBCAdapter/code/jars and reload the Adapter-Package and all depending packages.

The connection should specify “driverType=thin” in the “Other Properties” field.

Oracle 12c is currently not officially supported for the webMethods Suite.

HTH and Regards,
Holger

Thanks Holger for the great elaborated info:)

All information in one w.r.t to JDBC adapter :slight_smile:

Thanks.

I am working on this type of services for several years now and have worked with all of the mentioned combinations (and some others no longer supported by SAG and Oracle).

Therefor it is very easy for me to recap these informations from my experience.

Regards,
Holger

Yes very true and recap from the experience and it helps all the community members: :smiley:

Thank for all your wisdom, I appreciate it.

I can’t show my original code, but i attach an example

when i create my new adapter notification with 2 tables with 1 join on t1.ORDER_ID = t2.ORDER_ID and i change the name in the “Output Field” of the expression t2.ORDER_ID by ORDER_ID_2 and i try to enable the notification i have one error:

note: this is from a virtual machine in SQL not in oracle but i have the same result in oracle

[color=red]

[/color]

But if I change the name without _2 and 2 … i can enable the notification

why i can’t? :frowning:

by the way, i have another adapter notification (and all development), with the same configuration “ORDER_ID_2” and “TRANSACTION_ID2”, and guess what… it works!, i can disable and enable the adapter every time… why?

i’m working on IS 7.1, and… i don’t have access to Server TWO and THREE u.u

word with some images is attach.

THX 4 UR HELP :wink:

ERROR.doc (467 KB)

Did you focus more on these ORA errors and try with your DBA help? I believe its nothing to do in the IS/Developer as it complains more of the DB table perspective invalid columns etc…

HTH,
RMG

Yes, i’ve validated the talbes and db’s, the problem here is that the objects: “table bufer”, “trigger table” and “secuence table”, from the adapter notification, are generated automatically by the tool and not in manual way =S.

But, if i change (alter/modify) those objects the problem now is the SQL instruction with the error, i dont know where lives this SQL instrucction of the adapter notification in the server.

(U.u)

The most curious thing here is, why one adapter works (older development) and why a new adapter don’t work?.. interesting.

I’m going keep searching of this issue, but any ideas are wellcome.

All the Adapter framework Notification metadata depends on the WmART package frame work.

“why one adapter works (older development) and why a new adapter don’t work?..”

From your above statement:
What is your older development and newer can you clarify you mean IS versions changed and the JDBC Adapter and ART fix levels different than old vs new?

HTH,
RMG

I had the same issue with an adapter notification using a join between 2 tables.

The way i was able to resolve it was to rename the output field from the first table (t1) not the second one (t2) for some reason that way the adapter it does starts.

i you want to use complex expressions (subquerys) you need to define it at the begining of the column list, otherwise the result is a messy query generated by the IS

En español:
Yo tuve el mismo problema con un adapter notification usando un join entre 2 tablas.

La manera en que lo pude resolver fue cambiando el nombre al output field de la primera tabla del join (sobre la que te pide notificarte en update) es decir la t1, en lugar de sobre la segunda, es decir la t2, de esa forma el adapter si se habilita.

Si quisieras usar una expression compleja (con querys internos o algo asi) necesitarías definirlo al principio de la lista de columnas, de otra manera el resultado es un query dificil de leer generado por el IS.

Espero sea de utilidad esta info.