EJB Adapter 6.0 :unable to run adapter

Hi All
I am using:

IS 6.5
Ejb Adapter 6.0
webMethods jvm 1.4.2
Developer 6.5
WebLogic 8.1
Weblogic jvm 1.4

I have an EJB deployed on WebLogic 8.1.This EJB has methods that takes an object as input.
I have created this object using java service in developer(as detailed in the EJB Adapter User guide).The Object is created all right,however when I try to pass this object to the adapter service, it throws an error :

An error occurred while tracing.

com.wm.app.b2b.server.ServiceException: [ART.117.4002] Adapter Runtime (Adapter Service): Unable to invoke adapter service varghese.weblogic.Test.Sample:sampleAdapter.
[ADA.640.5007] Failed to invoke remote method: printMessage, reason: argument type mismatch
argument type mismatch

I have tried to call the ejb outside of IS(local java application)and it works fine.

I have placed the jars in \packages\WmEJBAdapter\code\jars (weblogic and EJB).

I am creating the objects in a different package so had to place the jars in that package too.

am I missing something
Thanks in advance

I put all the jars in
\lib\jars\ file and it worked.

however am facing other problem.
Read at http://advantage.webmethods.com/article/?id=2000000058