Does 6.0.1 SP1 to 6.5 upgrade require Intermediate 6.1.x upgrade?

Planning to upgrade 6.0.1 SP2 to 6.5.1 and we have components like,

  1. Broker
  2. IS
  3. TN
  4. Modeler
  5. Monitor

After reading 6.0.1 to 6.5 upgrade documents for these components, upgrade related to Modeler and Monitor requires intermediate 6.1 upgrade. But, intermediate upgrade to these two component insists to install Integration Server 6.1 and the necessary database scripts/tables.

I see challanges in Monitor and Modeler upgrade.

My question is, Can you please detail,

  1. Which component can be directly upgraded from 6.0.1 to 6.5?

  2. Which component requires Intermediate upgrade? and What version and Service Pack (if any)?

  3. What are the Intermediate upgrade steps and Important steps to follow…including database upgrade and configuration?

Thanks in advance and appreciate for your time and knowledge sharing.

Thanks,
Siva

What did you learn from reading the release notes and the upgrade guides available on Advantage?

Need thoughts in Modeler and Monitor upgrade from 6.0.1 to 6.5.1.

  1. Upgrade documentation from IS 6.0.1 to 6.5.1 recommends to run ISCoreAudit database script directly to 6.5.1. Whereas, while reading Monitor upgrade document and webMethods SR recommends to upgrade ISCoreAudit, ProcessAuditLog database components from 6.0.1 -> 6.1 -> 6.1.5 -> 6.5.1

  2. During this intermediate upgrade steps, Do I need to install IS 6.1 and upgrade Modeler and Monitor? or running database scripts would be sufficient?

  3. Hints to Common errors/mistakes to avoid and check during upgrade?

  4. Pre and Post migration checking?

Any experiences or lesson learned would be highly welcome!!

Thanks,
Siva