Document is not getting published in the subscriber


[INDENT]1. Check If IS and Broker are running.
2.Create document and set Publishable property to True
3. Create two flows: Flows1 and Flows2
4. In Flows1 put pub.publish:publish with parameters documentTypeName is
your document FULL name;best is cut and paste; and document is this document.
5. Create trigger with flow2 and your document.
6. In menu synchronize your documents.
7. Thats all

If you run flow1, document will be publish and than subscribe to trigger and run flow2

I have done all the above said steps, but still im not getting the output(i.e document is ntot getting published in the subscriber)

Can anyone help me with this problem?

hi srividhya…

i think u must select the logged fields… mark them n run the pub n sub again …have fun …cheerio.!!

how do you say document is not published to broker? problem might be in subscriber… the trigger would be invoking a service… have you kept fully qualified name for the input publishable document? keep a debug log as the first statement and log some message… atleast u will know the flow has reached the service invoked through trigger…


hi senthil,
thanks for ur reply…
actually the input that we give in the publisher shd be displayed as the output in the subscriber, right? Im not getting that… if i run all the three publisher, broker and subscriber separately with different inputs its working fine…
Could you please tell me exactly what should be done with the subscriber process…

while invoking the service, in the input document, u will map the actual document from your pipeline. the path of that publishable document will be given in the documentTypeName input parameter. the input ‘locally’ will be set to false by default.

You will invoke a service from the trigger in the subscriber end. The input of that service should be this publishable document with its “fully qualified name”.

It is just that, there is some minor mistake in your code. Before that, make sure your IS is connected to Broker :slight_smile: IS Admin > Settings > Messaging < Broker Settings… Connected state should be ‘yes’.


Hi Srividhya,

As Senthil rightly elaborated steps, u just need a publishable document, publisher service, a trigger for that publishable doc and a subscriber service(Make sure IS is connected to a broker). “fully qualified name” means u just need to copy that document and paste exact name in ur subscriber input. I think you should be able to do with this information.