I configured an oracle adapter with the adapter configuration tool and it runs ok. When I tried to
implement a configured operation on this adapter,
I encounted the error: “This operation cannot be
completed because the adapter testAdapter is not running or has not been contacted yet”.
How do I resolve this problem?

Your answer is greatly appreciated!


sorry for wrong title in my previous message

Try the following (it doesn’t take away the problem, it just lessens the irritation). In EI, in Preferences, set the Adapter Polling interval to something way less than 300 seconds (I normally use 30) - the “error” occurs with some regularity (normally when you have a network that’s not too stable)


First make sure that the DB adapter has been correctly started and it is running in normal mode(not in debug mode).

Second, close the EI and restart it.

Then, you can check the DB adapter status from the EI. If the status has a DB icon there, this indicates the DB adapter is running and the EI has got the status.

Try to configure an operation. It will work.

Hope this will help you.


Did you install SP1? If yes, then reinstall EI
!without! SP1. I had exactly the same problem. The problem was solved as I reinstalled Ei without SP1. Perhaps SP1 has a problem with the dbAdapter (or vice versa…)


thanks for all suggestions.
I have tried all of them, but no any luck to get
it work. My EI does not have sp1 since my EI
tool will be in loading status forever if I
apply sp1. I believe that my db adapter was
configured properly since I could run a sample
code coming with the EI package to retrieve/insert
data from/into the same database. But when I tried
to create a new configured operation for the adapter, I run into the same complaint.

My system configuration is as follow: ES is
hosted on a unix box. database is hosted on another
unix box. EI and adapter configuration tools are
installed on my local pc with win2000.

Any suggestion?

Your reply is appreciated!