Designer process file is broken

Hi, I’m working with Desinger 7.1 and I’ve lost a process file in my local machine. This process is in MWS and work fine.

How can I rebuild a process in my local machine from MWS?


You can fetch the process defination xml from Process Defination table. It will be a blob object of XML.

Hi, many thanks.
Perfect. I rebuilt my process design perfectly.

Thanks again.

I have a similar issue, i have a process model with task step in it, our admin checked in process file and portlets in VCS. somehow it is screwed up, i can import the process file but i can not see task implementation(task portlets) in Designer when i click on the task step in the process model. It is working fine in MWS, how can i restore the portlets.

Please advice…

Have you tried the above said from the Process Definition Table…just in case…


I found backup of process project and CAF project,created a new workspace and imported it.

Thanks RMG.

Good you had backup.

Other option you may try if you find again in this solution: (although I haven’t tried it)
Portal project in deployed in MWS deploy directory, if by mistake u loose workspace then try to get deom deploy directory (check it if it works)