Deploy Tamino API for Java

Hi! In order to use the Tamino API, do I need to do anything? :confused:
I read in the Tamino API for Java that I need to set the classpath to include the jar files. I did that already, but the java file that I’m working on, the import statements have problems reading the files as the warning says the files do not exist.

Why is that so? :rolleyes:

Thank you all for helping!

HI there,

I think a good starting point would be to post an exact copy of the errors you are getting. As a guess your most likely problem is that you are not setting up the CLASSPATH correctly.

What platform are you using and what jdk/jre do you have?

Kind regards,

Simon

Hi, thank you for replying. In the java class I wrote this

package com.softwareag.tamino.db.api.examples.greeting;

import com.softwareag.tamino.db.api.accessor.;

When I compile the file, the error was:

C:\Documents and Settings\Administrator\Desktop\GetInput.java:3: package com.softwareag.tamino.db.api.accessor does not exist
import com.softwareag.tamino.db.api.accessor.
;

The current version that I use for jdk 1.3.1_03.
The problem occurs only when I import tamino lib.
Maybe you are right, I might set the classpath wrongly.
I wrote this: C:\Program Files\Software AG\Tamino\Tamino 3.1.1.1\SDK\TaminoAPI4J\lib;C:\Program Files\Software AG\Tamino\Tamino 3.1.1.1\SDK\TaminoAPI4J\examples

Do you think there’s anything wrong with it? :smiley:

Hi KAren,

yes, there is something wrong with your classpath. It is necessary to specify the individual .jar files in the classpath, not just the …\TaminoAPI4J\lib directory.

So, for example, you need to have something like this:
C:\Program Files\Software AG\Tamino\Tamino 3.1.1.1\SDK\TaminoAPI4J\lib\TaminoAPI4J.jar;C:\Program Files\Software AG\Tamino\Tamino 3.1.1.1\SDK\TaminoAPI4J\lib\xerces.jar;C:\Program Files\Software AG\Tamino\Tamino 3.1.1.1\SDK\TaminoAPI4J\lib\jdom.jar;C:\Program Files\Software AG\Tamino\Tamino 3.1.1.1\SDK\TaminoAPI4J\lib\log4j-core.jar;

Hope that helps,
Trevor.

Hey Simon and Trevor,

Thank you so much for your help! I managed to get it working.

Trevor>> I did what you told me about the classpath. I also add the files into c:\jdk1.3.1_03\jre\lib\ext. It works!

Thank you again!
:cool: