Creating KPI

I have created a business process in Designer, with a KPI fact “lastValue” (which is a number) and dimension “Province” and aggregation type “last value”. I have uploaded this, and when I run instances of my process, my KPI is created and seems to be working fine. If I look at the eventMap that was created, it has an eventType = “MyProcess - BPMDoc/doc”

Now, in MWS, I would like to create a new KPI that would give me the average value for the dimension “Province”. What I did was:

  • Create a new eventMap “testAverage” for my business process. I see the eventType to a new value, “eventTypeTest”
  • Add a field named “Province”, of type=dimension, and I selected the existing dimension “Province”
  • Add a field named “averageCount”, of type=measure, calculation type=average
  • Create a KPI named “averageValuePerProvince”, selected my new eventMap and dimension. When I select my eventMap, my KPI is set automatically to calculation “Average”, which is good.

But if I run process instances, I don’t see any data for this average KPI, even if I see data for the base KPI that was created in Designer.

Is there anything that I’m missing? Where is it going wrong?

Thanks a lot for your help,



Try to access to Monitoring->System-Wide->Analytics Overview. Check if exists your KPI in the dropdown list in the upper right corner. Also check if the server (dropdown) is “BPM & BAM”. Also check if the BAM is running without errors.

Best regards.

Make sure, your business process model is ‘enabled for analysis’



Yes my process is enabled for analysis. Strange thing though, even if there are process instances, it says “Used” = No…

When I go the the analytics view and select server “BPM and BAM”, I don’t see my KPI averageValuePerProvince. In the top right corner, I have the dropdown list for server, and just below the dropdown list for overview configuration, in this one “Analytics Business View” is selected. Do I have to somehow give permission to see this KPI?



Go to Administration->Analytics->Overview Configuration. Click on “Add Configuration”, Don’t forget to check “Shared” to see the kpi in the dropdown mentioned above. Here you have to chose the event map you have created
previously. Read the documentation for more details.


The only dropdown I see in the top right corner is the one with the overview configurations, I don’t see any KPI in it.
I have created a new configuration and selected my process and the 2 KPI (the one created in Designer, and the one I created in MWS), I can’t select an event map when I create a configuration.
And even then, when I go to Analytics overview and select this new configuration, I still see only the KPI created in Designer.
Can I somehow check in the database that everything is configured properly? What should I look for?